Find the answer to your Linux question:
Results 1 to 8 of 8
i tried reinstalling gst-plugins-base like it said and it didnt work Cannot find required GStreamer-0.10 plugin 'playbin'. It should be part of gst-plugins-base. Please install it. !!! Please attach the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Enthusiast crashandburn0420's Avatar
    Join Date
    Jun 2005
    Location
    Naugatuck, CT
    Posts
    590

    emerge -uvD world error


    i tried reinstalling gst-plugins-base like it said and it didnt work

    Cannot find required GStreamer-0.10 plugin 'playbin'.
    It should be part of gst-plugins-base. Please install it.


    !!! Please attach the following file when filing a report to bugs.gentoo.org:
    !!! /var/tmp/portage/totem-1.4.0/work/totem-1.4.0/config.log

    !!! ERROR: media-video/totem-1.4.0 failed.
    Call stack:
    ebuild.sh, line 1539: Called dyn_compile
    ebuild.sh, line 939: Called src_compile
    totem-1.4.0.ebuild, line 125: Called gnome2_src_compile
    gnome2.eclass, line 63: Called gnome2_src_configure
    gnome2.eclass, line 59: Called econf '--disable-vanity' '--disable-gtk' '--without-dbus' '--enable-nautilus' '--disable-lirc' '--enable-mozilla' '--with-mozilla=gecko-sdk' '--disable-nvtv' '--enable-gstreamer=0.10' 'MOZILLA_PLUGINDIR=/usr/lib/nsbrowser' '--disable-gtk-doc'
    ebuild.sh, line 541: Called die

    !!! econf failed
    !!! If you need support, post the topmost build error, and the call stack if relevant.

  2. #2
    Linux Engineer d38dm8nw81k1ng's Avatar
    Join Date
    Mar 2005
    Location
    Newcastle
    Posts
    793
    try using -nuDav (nuD is recommended by the gentoo team) and you'll be able to view the USEflags. the nuD should at least get it to compile.
    Here's why Linux is easier than Windows:
    Package Managers! Apt-Get and Portage (among others) allow users to install programs MUCH easier than Windows can.
    Hardware Drivers. In SuSE, ALL the hardware is detected and installed automatically! How is this harder than Windows' constant disc changing and rebooting?

  3. #3
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    Or, if you think you are missing libs, run a
    Code:
    revdep-rebuild -p
    To see what you need. When that is finished, remove the -p and let it rebuild what it wants.

    If you still have compile errors, then try to compile the gst-plugins package again. Sometimes when compiles fail (on my machine anyway) just try a couple more times, and it will complete depending on if you have ccache, distcc, confcache, or some other options enabled.

    And yes, if I am updating, I always do a -avuDN world.
    --ask --verbose --update --Deep --Newuse
    That way it updates all dependencies and your whole system will stay updated.

    Linux User #376741
    Code is Poetry

  4. #4
    Linux Enthusiast crashandburn0420's Avatar
    Join Date
    Jun 2005
    Location
    Naugatuck, CT
    Posts
    590
    This is what i get
    localhost steven # revdep-rebuild
    Configuring search environment for revdep-rebuild

    Checking reverse dependencies...

    Packages containing binaries and libraries broken by a package update
    will be emerged.

    Collecting system binaries and libraries... done.
    (/root/.revdep-rebuild.1_files)

    Collecting complete LD_LIBRARY_PATH... done.
    (/root/.revdep-rebuild.2_ldpath)

    Checking dynamic linking consistency...
    broken /usr/bin/aim (requires libstdc++-libc6.1-1.so.2)
    broken /usr/bin/evolution-2.4 (requires libecal-1.2.so.3 libedataserver-1.2.so.4)
    broken /usr/bin/giftd (requires libMagick.so.6)
    broken /usr/bin/gnome-system-monitor (requires libgtop-2.0.so.5)
    broken /usr/bin/less (requires libncursesw.so.5)
    broken /usr/bin/xfcalendar (requires libxfce4mcs-client.so.2 libxfce4util.so.1)
    broken /usr/bin/xfce4-menueditor (requires libxfce4mcs-client.so.2 libxfce4util.so.1)
    broken /usr/bin/xfdesktop (requires libxfce4mcs-client.so.2 libxfce4util.so.1)
    broken /usr/bin/xfdiff4 (requires libxfce4util.so.1)
    broken /usr/bin/xffm (requires libxfce4mcs-client.so.2 libxfce4util.so.1)
    broken /usr/bin/xfmime-edit (requires libxfce4util.so.1)
    broken /usr/bin/xfprint-manager (requires libxfce4mcs-client.so.2 libxfce4util.so.1)
    broken /usr/bin/xfprint4 (requires libxfce4mcs-client.so.2 libxfce4util.so.1)
    broken /usr/bin/xfwm4 (requires libxfce4mcs-client.so.2 libxfce4util.so.1)
    broken /usr/lib/aim/feed.so.1 (requires libstdc++-libc6.1-1.so.2)
    broken /usr/lib/aim/service.so.1 (requires libstdc++-libc6.1-1.so.2)
    broken /usr/lib/aim/ui.so.1 (requires libstdc++-libc6.1-1.so.2)
    broken /usr/lib/evolution/2.4/components/libevolution-addressbook.so (requires libedataserver-1.2.so.4)
    broken /usr/lib/evolution/2.4/components/libevolution-calendar.so (requires libcamel-provider-1.2.so.6 libecal-1.2.so.3 libedataserver-1.2.so.4)
    broken /usr/lib/evolution/2.4/components/libevolution-mail.so (requires libcamel-provider-1.2.so.6 libedataserver-1.2.so.4)
    broken /usr/lib/evolution/2.4/libeabutil.so.0.0.0 (requires libedataserver-1.2.so.4)
    broken /usr/lib/evolution/2.4/libeconduit.so.0.0.0 (requires libedataserver-1.2.so.4)
    broken /usr/lib/evolution/2.4/libecontacteditor.so.0.0.0 (requires libedataserver-1.2.so.4)
    broken /usr/lib/evolution/2.4/libecontactlisteditor.so.0.0.0 (requires libedataserver-1.2.so.4)
    broken /usr/lib/evolution/2.4/libemiscwidgets.so.0.0.0 (requires libedataserver-1.2.so.4)
    broken /usr/lib/evolution/2.4/libessmime.so.0.0.0 (requires libedataserver-1.2.so.4)
    broken /usr/lib/evolution/2.4/libeutil.so.0.0.0 (requires libedataserver-1.2.so.4)
    broken /usr/lib/evolution/2.4/libevolution-addressbook-a11y.so.0.0.0 (requires libedataserver-1.2.so.4)
    broken /usr/lib/evolution/2.4/libevolution-addressbook-importers.so.0.0.0 (requires libcamel-provider-1.2.so.6 libedataserver-1.2.so.4)
    broken /usr/lib/evolution/2.4/libevolution-calendar-a11y.so.0.0.0 (requires libecal-1.2.so.3 libedataserver-1.2.so.4)
    broken /usr/lib/evolution/2.4/libevolution-calendar-importers.so.0.0.0 (requires libecal-1.2.so.3 libedataserver-1.2.so.4) broken /usr/lib/evolution/2.4/libevolution-mail-importers.so.0.0.0 (requires libcamel-provider-1.2.so.6 libedataserver-1.2.so.4)
    broken /usr/lib/evolution/2.4/libevolution-smime.so.0.0.0 (requires libedataserver-1.2.so.4)
    broken /usr/lib/evolution/2.4/libevolution-widgets-a11y.so.0.0.0 (requires libedataserver-1.2.so.4)
    broken /usr/lib/evolution/2.4/libfilter.so.0.0.0 (requires libedataserver-1.2.so.4)
    broken /usr/lib/evolution/2.4/plugins/libmail-account-disable.so (requires libcamel-provider-1.2.so.6 libedataserver-1.2.so.4)
    broken /usr/lib/evolution/2.4/plugins/liborg-gnome-addressbook-file.so (requires libedataserver-1.2.so.4)
    broken /usr/lib/evolution/2.4/plugins/liborg-gnome-calendar-file.so (requires libecal-1.2.so.3 libedataserver-1.2.so.4)
    broken /usr/lib/evolution/2.4/plugins/liborg-gnome-calendar-http.so (requires libecal-1.2.so.3 libedataserver-1.2.so.4)
    broken /usr/lib/evolution/2.4/plugins/liborg-gnome-calendar-weather.so (requires libecal-1.2.so.3 libedataserver-1.2.so.4) broken /usr/lib/evolution/2.4/plugins/liborg-gnome-default-source.so (requires libecal-1.2.so.3 libedataserver-1.2.so.4)
    broken /usr/lib/evolution/2.4/plugins/liborg-gnome-evolution-startup-wizard.so (requires libcamel-provider-1.2.so.6 libecal-1.2.so.3 libedataserver-1.2.so.4)
    broken /usr/lib/evolution/2.4/plugins/liborg-gnome-groupwise-features.so (requires libcamel-provider-1.2.so.6 libecal-1.2.so.3 libedataserver-1.2.so.4 libegroupwise-1.2.so.
    broken /usr/lib/evolution/2.4/plugins/liborg-gnome-gw-account-setup.so (requires libcamel-provider-1.2.so.6 libecal-1.2.so.3 libedataserver-1.2.so.4 libegroupwise-1.2.so.
    broken /usr/lib/evolution/2.4/plugins/liborg-gnome-itip-formatter.so (requires libcamel-provider-1.2.so.6 libecal-1.2.so.3 libedataserver-1.2.so.4)
    broken /usr/lib/evolution/2.4/plugins/liborg-gnome-mark-all-read.so (requires libcamel-provider-1.2.so.6 libedataserver-1.2.so.4)
    broken /usr/lib/evolution/2.4/plugins/liborg-gnome-plugin-manager.so (requires libcamel-provider-1.2.so.6 libedataserver-1.2.so.4)
    broken /usr/lib/evolution/2.4/plugins/liborg-gnome-print-message.so (requires libcamel-provider-1.2.so.6 libedataserver-1.2.so.4)
    broken /usr/lib/gdesklets/libdesklets/system/gtop.so (requires libgtop-2.0.so.5)
    broken /usr/lib/libextgtk.so.1 (requires libstdc++-libc6.1-1.so.2)
    broken /usr/lib/libextractor/libextractor_thumbnail.so (requires libMagick.so.6 libWand.so.6)
    broken /usr/lib/libxfcegui4.so.3.0.5 (requires libxfce4util.so.1)
    broken /usr/lib/python2.4/lib-dynload/_curses.so (requires libncursesw.so.5)
    broken /usr/lib/python2.4/lib-dynload/_curses_panel.so (requires libncursesw.so.5)
    broken /usr/lib/python2.4/lib-dynload/readline.so (requires libncursesw.so.5)
    broken /usr/lib/xfce4/mcs-plugins/libxffmsettings.so (requires libxfce4mcs-client.so.2 libxfce4mcs-manager.so.2 libxfce4util.so.1)
    broken /usr/lib/xfce4/mcs-plugins/workspaces_plugin.so (requires libxfce4mcs-manager.so.2 libxfce4util.so.1)
    broken /usr/lib/xfce4/mcs-plugins/xfprint_plugin.so (requires libxfce4mcs-manager.so.2 libxfce4util.so.1)
    broken /usr/lib/xfce4/mcs-plugins/xfwm4_plugin.so (requires libxfce4mcs-manager.so.2 libxfce4util.so.1)
    broken /usr/lib/xfce4/modules/xfce4_desktop_menu.so (requires libxfce4util.so.1)
    broken /usr/lib/xfce4/panel-plugins/libdesktopmenu.so (requires libxfce4util.so.1)
    broken /usr/lib/xfce4/xfprint-plugins/bsdlpr_plugin.so (requires libxfce4util.so.1)
    broken /usr/lib/xfce4/xfprint-plugins/cups_plugin.so (requires libxfce4util.so.1)
    broken /usr/libexec/clock-applet (requires libecal-1.2.so.3 libedataserver-1.2.so.4)
    broken /usr/libexec/evolution-webcal (requires libecal-1.2.so.3 libedataserver-1.2.so.4)
    broken /usr/libexec/evolution/2.4/evolution-addressbook-export (requires libedataserver-1.2.so.4)
    broken /usr/libexec/evolution/2.4/evolution-alarm-notify (requires libcamel-provider-1.2.so.6 libecal-1.2.so.3 libedataserver-1.2.so.4)
    broken /usr/libexec/evolution/2.4/killev (requires libedataserver-1.2.so.4)
    broken /usr/libexec/multiload-applet-2 (requires libgtop-2.0.so.5)
    broken /usr/local/lib/gdesklets/libdesklets/system/gtop.so (requires libgtop-2.0.so.5)
    broken /usr/local/lib/libdivxencore.so (requires libstdc++-libc6.2-2.so.3)
    done.
    (/root/.revdep-rebuild.3_rebuild)

    Assigning files to ebuilds... done.
    (/root/.revdep-rebuild.4_ebuilds)

    Evaluating package order...
    Warning: Failed to resolve package order.
    Will merge in "random" order!
    Possible reasons:
    - An ebuild is no longer in the portage tree.
    - An ebuild is masked, use /etc/portage/packages.keyword
    and/or /etc/portage/package.unmask to unmask it
    ..... done.
    (/root/.revdep-rebuild.5_order)

    All prepared. Starting rebuild...
    emerge --oneshot =dev-lang/python-2.4.3-r1 =gnome-base/gnome-applets-2.12.3 =gnome-base/gnome-panel-2.12.3 =gnome-extra/evolution-webcal-2.4.1 =gnome-extra/gdesklets-core-0.35.3 =gnome-extra/gnome-system-monitor-2.12.2 =mail-client/evolution-2.4.2.1 =media-libs/libextractor-0.5.0 =net-p2p/gift-0.11.6-r1 =sys-apps/less-385_p4-r2 =xfce-base/libxfcegui4-4.2.2 =xfce-base/xfdesktop-4.2.2 =xfce-base/xffm-4.2.2 =xfce-base/xfprint-4.2.2 =xfce-base/xfwm4-4.2.2 =xfce-extra/xfcalendar-4.2.2
    ..........
    Calculating dependencies -
    emerge: there are no ebuilds to satisfy "=media-libs/libextractor-0.5.0".


    revdep-rebuild failed to emerge all packages
    you have the following choices:

    - if emerge failed during the build, fix the problems and re-run revdep-rebuild
    or
    - use -X or --package-names as first argument (trys to rebuild package, not exact
    ebuild)
    or
    - set ACCEPT_KEYWORDS="~<your platform>" and/or /etc/portage/package.unmask
    (and remove /root/.revdep-rebuild.5_order to be evaluated again)
    or
    - modify the above emerge command and run it manually
    or
    - compile or unmerge unsatisfied packages manually, remove temporary files and
    try again (you can edit package/ebuild list first)

    To remove temporary files, please run:
    rm /root/.revdep-rebuild*.?_*

  5. #5
    Just Joined! Rainskellr's Avatar
    Join Date
    Jun 2006
    Location
    init 1
    Posts
    15
    Eww, messy.

    emerge: there are no ebuilds to satisfy "=media-libs/libextractor-0.5.0".

    I don't see that specific version in the tree.
    equery is a part of the gentoolkit package.
    Code:
    srishti ~ # equery l -p media-libs/libextractor
    [ Searching for package 'libextractor' in 'media-libs' among: ]
     * installed packages
     * Portage tree (/usr/portage)
    [-P-] [  ] media-libs/libextractor-0.5.14 (0)
    I would start by updating that package and see if revdep can handle the rest.

    Good Luck

  6. #6
    Just Joined! Rainskellr's Avatar
    Join Date
    Jun 2006
    Location
    init 1
    Posts
    15
    Ohh, Rgarding your original error message in the first post, I found this in bugzilla.
    http://bugs.gentoo.org/show_bug.cgi?id=132506

  7. #7
    Linux Enthusiast crashandburn0420's Avatar
    Join Date
    Jun 2005
    Location
    Naugatuck, CT
    Posts
    590
    Quote Originally Posted by Rainskellr
    Ohh, Rgarding your original error message in the first post, I found this in bugzilla.
    http://bugs.gentoo.org/show_bug.cgi?id=132506
    In the bug report heres the error with this
    Regarding comment #3, running "gst-inspect-0.10 playbin" fails with a
    segmentation fault:

    $ gst-inspect-0.10 playbin

    ERROR: Caught a segmentation fault while loading plugin file:
    /usr/lib64/gstreamer-0.10/libgstvideotestsrc.so

    Please either:
    - remove it and restart.
    - run with --gst-disable-segtrap and debug.
    I get
    localhost steven # gst-inspect-0.10 playbin

    ERROR: Caught a segmentation fault while loading plugin file:
    /usr/lib/gstreamer-0.10/libgstaudioresample.so

    Please either:
    - remove it and restart.
    - run with --gst-disable-segtrap and debug.
    No such element or plugin 'playbin'

    And for this one
    I am using gcc-4.1.0. Changing the compilation options when emerging liboil
    makes a difference.

    With liboil compiled with CFLAGS="-march=k8 -O2 -pipe", the segmentation fault
    is gone and I can emerge totem.

    When liboil is compiled with CFLAGS="-march=k8 -O2 -pipe -frename-registers
    -fweb -ftree-vectorize -mfpmath=sse -funswitch-loops -fgcse-after-reload", the
    command "gst-inspect-0.10 playbin" causes a segmentation fault and totem cannot
    be emerged.
    I dont know how to change CFLAGS

  8. #8
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    I would try to fix the revdep-rebuild problem before anything else.

    Make sure and sync your portage tree before anything though. If you have a problem while emerging, then when if faults out, run an emerge --resume --skipfirst. That will allow it to continue installing until it finishes. Then run your revdep-rebuild.

    Linux User #376741
    Code is Poetry

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •