Find the answer to your Linux question:
Results 1 to 6 of 6
I just installed gentoo, and when I boot linux show an "Error initializing random number generator" How can I fix this? Thanks...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2006
    Posts
    3

    Random Number Generator


    I just installed gentoo, and when I boot linux show an "Error initializing random number generator"

    How can I fix this?
    Thanks

  2. #2
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    How did you configure RTC in the kernel?
    Code:
    cat /boot/config-$(uname -r) | grep -i rtc
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  3. #3
    Just Joined!
    Join Date
    Jul 2006
    Posts
    3
    CONFIG_RTC is not set
    CONFIG_GEN_RTC is not set

  4. #4
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    If hw_random set as a module or built-in?
    Code:
    cat /boot/config-$(uname -r) | grep -i hw_random
    You can set it (in "make menuconfig") in :
    Device Drivers ---> Character devices ---> <*> Intel/AMD/VIA HW Random Number Generator support

    But it is really not that important, it doesn't work on many of my machines either, so I often disable it.

    You should set your RTC though :
    Device Drivers ---> Character devices ---> <M> Enhanced Real Time Clock Support
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  5. #5
    Just Joined!
    Join Date
    Jul 2006
    Posts
    3
    The error is still there... how can i disable it?

  6. #6
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Then disable the Random Number Generator, your motherboard/CPU doesn't like it.

    Read /usr/src/linux-$(uname -r)/Documentation/hw_random.txt for more.

    Anyway hw_random has no use unless you installed "rng-tools" on your system :
    http://sourceforge.net/projects/gkernel
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •