Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
Hello, I am sure you have all seen a wealth of Grub-related problems. I have one that I have not been able to solve despite hours of searching and messing ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2006
    Posts
    10

    Grub Problems


    Hello,

    I am sure you have all seen a wealth of Grub-related problems. I have one that I have not been able to solve despite hours of searching and messing around. So much so that I have decided to join this forum to find a solution.

    Anyway, here is how my system is set up.

    I have three hard drives, hda, hdb and hdd. hda has Gentoo Linux on it, as well as Grub (hda1). hdb is just a spare hard drive that I use for backups. hdd has Windows XP on it.

    Here is the output of fdisk -l just for the sake of it:

    Code:
    Disk /dev/hda: 80.0 GB, 80026361856 bytes
    16 heads, 63 sectors/track, 155061 cylinders
    Units = cylinders of 1008 * 512 = 516096 bytes
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/hda1   *           1          63       31720+  83  Linux
    /dev/hda2              64        1056      500472   82  Linux swap / Solaris
    /dev/hda3            1057      155061    77618520   83  Linux
    
    Disk /dev/hdb: 80.0 GB, 80026361856 bytes
    16 heads, 63 sectors/track, 155061 cylinders
    Units = cylinders of 1008 * 512 = 516096 bytes
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/hdb1   *           1      155061    78150712+  83  Linux
    
    Disk /dev/hdd: 80.0 GB, 80026361856 bytes
    255 heads, 63 sectors/track, 9729 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/hdd1   *           1        9728    78140128+   7  HPFS/NTFS
    What I want to be able to do is use Grub to boot either Windows XP of Linux. I have read about two billion and twelve sites all saying similar things. I have seen about another one billion with people having a similar problem to me, and not finding a solution. I have tried all sorts of things. Most of the time it results in Grub giving me an Error 13.

    Because of this I have removed the Windows XP part from my grub.conf completely and I am hoping that you guys can provide me with some ideas. I will try them, and then report back.

    Any help would be most appreciated as this is driving me insane.

    I just had a though, is it possible that the configuration of the drives' jumper pins affects this at all? (Seeing as I have 3 hard drives, two on one IDE channel and one on another, with a CD drive).

    Thanks.

  2. #2
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    Try this in your grub.conf
    Code:
    title=Windows XP
            map (hd0) (hd3)
            map (hd3) (hd0)
    	rootnoverify (hd3,0)
    	makeactive
    	chainloader +1
    If that doesn't work, just play around with the map option. You have to make XP think it is on the first hard drive, and that is essentially what we have done. Also, make sure in this setup that you have provided, that the jumpers are set correctly as master/slave.

    Grub counts your hard drives from 0, so hda=0, hdb=1, hdc=2, and hdd=3. Your partition would follow that, counting from 0. Post back and let me know if this works.

    Also, if it doesn't, post your old grub.conf so I can look over it.

    Linux User #376741
    Code is Poetry

  3. #3
    Just Joined!
    Join Date
    Jul 2006
    Posts
    10
    I have tried that at least 20 times.

    It gives me an error 13.

    I will try it again now just incase.

    By the way, hdd is actually hd2, not 3. Here is my device.map fille.

    Code:
    (fd0)	/dev/fd0
    (hd0)	/dev/hda
    (hd1)	/dev/hdb
    (hd2)	/dev/hdd
    My old grub.conf looked the exact same as the one you posted except with hd2 not hd3.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jul 2006
    Posts
    10
    Your advice did not work. It resulted in the same error.

    Error 13. The one about non supported executable format.

    Thanks anyway.

  6. #5
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    You can try setting the harddrive as master on the second IDE channel, which would make it hdc, and make sure your jumpers are set for master and slave. It is usually recommended to set the harddrive as master if on the same cable as a cdrom anyway (not sure why, but I haven't had problems doing it so far).

    I am looking for other possible solutions also.

    I guess it is possible that windows has to be on the primary channel, but I don't know. That is just a shot in the dark. It is worth a try though. I would try putting it on the first channel and see if it makes a difference. It may really mess with the windows install though.

    Linux User #376741
    Code is Poetry

  7. #6
    Just Joined!
    Join Date
    Jul 2006
    Posts
    10
    I don't think that Windows has to be on the primary chanel as I can boot it by changing the drive order in my BIOS.

    Another interesting point: If I change rootnoverify to root (so I can get some more info) it says that the filesystem is ex2fs. I dunno what that's on about.

    I will try your suggestion though.

  8. #7
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    I am just throwing things out there. I am actually searching around, but much beyond "error 13" is asking a lot, haha.

    Here is an idea also, the partition type ID
    http://www.redhat.com/archives/fedor.../msg00294.html

    And you also may want to make sure the partition is bootable (with the bootable flag in fdisk).

    I am sure I can think of something else, and will post it when I think of it.

    Linux User #376741
    Code is Poetry

  9. #8
    Just Joined! Rainskellr's Avatar
    Join Date
    Jun 2006
    Location
    init 1
    Posts
    15
    Grub - what a maggot!
    Quote Originally Posted by cameron10
    Another interesting point: If I change rootnoverify to root (so I can get some more info) it says that the filesystem is ex2fs. I dunno what that's on about.
    After remaping the drives in grub.conf with map Try ponting rootnoverify to (hd0,0). I think since they have been remaped (hd2,0) should now be at (hd0,0).

  10. #9
    Just Joined!
    Join Date
    Jul 2006
    Posts
    10
    Thanks for the replies guys.

    I have tried changing the rootnoverify thing to (hd0,0), gives me the same friggin error. I haven't, however, tried using root(hd0,0) I will try that and see what messages come up.

    On the drive that Windows is on, the partition certainly has the bootable flag active.

    I haven't tried messing around with the jumper pins and IDE chanels YET. Hopefully I will find time to do that later today.

    Thanks again.

    Edit: I am sad to report that by changing (hd2,0) with (hd0,0) made no difference at all.

  11. #10
    Just Joined!
    Join Date
    Jul 2006
    Posts
    12

    Error 15:

    Hello, I just finished installing gentoo, and after installing Grub I cannot boot the system. I could swear I followed the instructions to the letter, but this looked like the place to post for grub related issues. The specific error I receive is Error 15: file not found

    Code:
    booting ‘Gentoo Linux 2.6.16’
    root (hd1,0)
    Filesystem type is ext2fs, partition type 0x83
    kernel /boot/kernel-genkernel-x86-2.6.16-gentoor12 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/sda3 udev vga=0x307
    
    Error 15: file not found
    My grub.conf reads:

    Code:
    default=0
    timeout 30
    splashimage=(hd1,0)/boot/grub/splash.xpm.gz
    
    title=Gentoo Linux 2.6.16
    Root (hd1,0)
    Filesystem type is ext2fs, partition type 0x83
    kernel /boot/kernel-genkernel-x86-2.6.16-gentoo-r12 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/sda3 udev vga=0x307
    initrd /boot/initramfs-genkernel-x86-2.6.16-gentoo-r12
    I have a SATA HD on which I installed Gentoo, and there is a regular IDE HD installed as well. The SATA hd is partition as

    /dev/sda1 /boot
    /dev/sda2 – swap
    /dev/sda3 /

    I reloaded the install cd and chrooted, both the initrd and kernel appear to be in /boot, and grub-install reported installing grub without any errors. The system.map sees /sda as (hd1). Any ideas or feedback is appreciated. Thanks in advance.

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •