Find the answer to your Linux question:
Results 1 to 2 of 2
I recently did something to mess up bash and kde, but unfortunately, I don't know exactly what that was, because I didn't notice at first. Here are the symptoms: I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2005
    Posts
    7

    bash 'type' command and mime-types errors


    I recently did something to mess up bash and kde, but unfortunately, I don't know exactly what that was, because I didn't notice at first. Here are the symptoms:

    I have a text file called 'todo.txt'. On a command line, in bash:
    [confuted@alpha ~]$ type todo.txt
    bash: type: todo.txt: not found

    I know this command has worked in the past for me. I tried re-emerging bash, but it didn't solve my problem.

    I imagine that error is associated in some way with this error:
    When I start openoffice (and sometimes other programs. Konqueror has had symptoms), and try to open a document, I get the following orders in sequence:
    Could not find mime-type: application/octet-stream
    No mime types installed
    Malformed URL file:///usr/lib/openoffice/program
    Malformed URL file:///home/confuted/

    Similar crap pops up when I try to save, and then openoffice crashes. I tried re-emerging openoffice, too, but if that had worked, I wouldn't be posting here.

    Any ideas?

  2. #2
    Linux Engineer rcgreen's Avatar
    Join Date
    May 2006
    Location
    the hills
    Posts
    1,134
    type [-aftpP] name [name ...]
    With no options, indicate how each name would be interpreted if used as a command name. If the -t option is used, type prints a string which is one of alias, keyword, function, builtin, or file if name is an alias, shell reserved word, function, builtin, or disk file, respectively. If the name is not found, then nothing is printed, and an exit status of false is returned. If the -p option is used, type either returns the name of the disk file that would be executed if name were specified as a command name, or nothing if ``type -t name'' would not return file. The -P option forces a PATH search for each name, even if ``type -t name'' would not return file. If a command is hashed, -p and -P print the hashed value, not necessarily the file that appears first in PATH. If the -a option is used, type prints all of the places that contain an executable named name. This includes aliases and functions, if and only if the -p option is not also used. The table of hashed commands is not consulted when using -a. The -f option suppresses shell function lookup, as with the command builtin. type returns true if any of the arguments are found, false if none are found.
    http://linux.about.com/library/cmd/blcmdl1_type.htm

    It is not like the DOS type command for displaying a file. For that you would
    do cat <filename>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •