Find the answer to your Linux question:
Results 1 to 3 of 3
I tried to install media-sound/listen, and one of its deps is dev-python/pysqlite-2.0.5 unortunatly the package is blocked by dev-db/sqlite-3.3.3 so i tried to unmerge dev-db/sqlite-3.3.3, and then portage says that ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2006
    Posts
    5

    Strange package blocking [solved]


    I tried to install media-sound/listen, and one of its deps is dev-python/pysqlite-2.0.5
    unortunatly the package is blocked by
    dev-db/sqlite-3.3.3

    so i tried to unmerge dev-db/sqlite-3.3.3, and then portage says that i don't have it installed. Actually i didn't even found the 3.3.3 version in gentoo-portage.com

    whats going on?
    Last edited by tourist76; 08-04-2006 at 08:40 PM. Reason: Solved

  2. #2
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    try emerging the ~x86 version of pysqlite. It is 2.0.7 and does not have a sqlite as a blocked dependency.

    to do this just edit

    /etc/portage/package.keywords

    and add this line

    dev-db/sqlite ~x86
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  3. #3
    Just Joined!
    Join Date
    Aug 2006
    Posts
    5
    Thanks, it worked. Now i have listen installed, but it won't start...
    but i think it's a different story, thanks anyway

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •