Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 22
got it to boot normally, thanks for all the help guys...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Jul 2006
    Posts
    33

    got it to boot normally, thanks for all the help guys

  2. #12
    Just Joined!
    Join Date
    Aug 2006
    Posts
    5

    kernel panic

    Quote Originally Posted by jpulumbarit
    got past the error when i boot....

    now i have this though....


    *Checking root filesystem
    fsck.ext3: No such file or directory while trying to open /dev/ROOT
    /dev/ROOT:
    The superblock could not be read or does not describe a correct ext2 filesystem. If the device is valid and it really contains an ext2 filesystem (and not swap or ufs or someting else), then the superblock is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck - b 8193 <device>
    *Filesystem could not be fixed



    what the heck does that mean?? i think i forgot to configure something in the kernel, thats how i solved my last problem.

    What did you forget to configure? I am having the error:

    VFS: Cannot open root device "hda3" or unknown-block(0,0)
    Please append a correct "root=' boot option
    Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)


    I Have tried all the suggestions posted on this thread, but the error message continues. If anyone has any ideas, that would be great, thanks.

  3. #13
    Linux Enthusiast apoorv_khurasia's Avatar
    Join Date
    Feb 2005
    Posts
    624

    Post grub.conf please

    Please post your grub.conf here.
    "There is no sixth rule"
    --Rob Pike
    Registered Linux User: 400426 home page

  4. $spacer_open
    $spacer_close
  5. #14
    Just Joined!
    Join Date
    Aug 2006
    Posts
    5
    grub.conf below

    default 0
    timeout 30
    splashimage=(hd0,0)/boot/grub/splash.xpm.gz
    title=gentoo
    root (hd0,2)
    kernel (hd0,0)/kernel-2.6.17-gentoo-r4 root=/dev/hda3

  6. #15
    Linux Enthusiast apoorv_khurasia's Avatar
    Join Date
    Feb 2005
    Posts
    624
    Two questions:

    1. Are you sure your kernel image is in the root directory (/) and not in /boot ? Also make sure that your /boot partition is hd(0,0) or /dev/hda1.
    If not then change the kernel entry to:
    Code:
    kernel (hd0,0)/boot/kernel-2.6.17-gentoo-r4 ro root=/dev/hda3
    2. Are you sure you installed gentoo in /dev/hda3?
    Make appropriate corrections, if this is the case.
    "There is no sixth rule"
    --Rob Pike
    Registered Linux User: 400426 home page

  7. #16
    Linux Engineer d38dm8nw81k1ng's Avatar
    Join Date
    Mar 2005
    Location
    Newcastle
    Posts
    793
    that won't make a difference if /boot is on a separate partition. the /boot provided is only a symlink its root partition. (hd0,0)/kernel and (hd0,0)/boot/kernel are the same as each other. however, if you only have one big partition, then it will be in (hd0,?)/boot/kernel with the ? referring to the partition number as grub sees it. you look like you followed the guide, so your partition table will probably be the same.

    ok, now to refer to the problem. change root(hd0,2) to root(hd0,0). this will tell grub to look at the /boot partition which is where you really need to look. you can then change (hd0,0)/kernel to just /kernel or /boot/kernel depending on what you prefer. this is all assuming you set up your system according to the handbook.
    Here's why Linux is easier than Windows:
    Package Managers! Apt-Get and Portage (among others) allow users to install programs MUCH easier than Windows can.
    Hardware Drivers. In SuSE, ALL the hardware is detected and installed automatically! How is this harder than Windows' constant disc changing and rebooting?

  8. #17
    Just Joined!
    Join Date
    Aug 2006
    Posts
    5
    Quote Originally Posted by d38dm8nw81k1ng
    that won't make a difference if /boot is on a separate partition. the /boot provided is only a symlink its root partition. (hd0,0)/kernel and (hd0,0)/boot/kernel are the same as each other. however, if you only have one big partition, then it will be in (hd0,?)/boot/kernel with the ? referring to the partition number as grub sees it. you look like you followed the guide, so your partition table will probably be the same.

    ok, now to refer to the problem. change root(hd0,2) to root(hd0,0). this will tell grub to look at the /boot partition which is where you really need to look. you can then change (hd0,0)/kernel to just /kernel or /boot/kernel depending on what you prefer. this is all assuming you set up your system according to the handbook.

    This is what I had originally, but it didn't work. I have the kernel image inside both the boot and root directory. I installed gentoo to /dev/hda3... I can't figure out what is wrong. I prolly skipped something accidently during the install, so I will start over.

  9. #18
    Just Joined!
    Join Date
    Aug 2006
    Posts
    5
    So, I followed the manual from the beginning, and I am stil having the same problem...

    VFS: Cannot open root device "hda3" or unknown-block(0,0)
    Please append a correct "root=' boot option
    Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)


    grub.conf is:

    default 0
    timeout 30
    splashimage=(hd0,0)/boot/grub/splash.xpm.gz
    title=gentoo 2.6.17-gentoo-r4
    root (hd0,0)
    kernel /boot/kernel-2.6.17-gentoo-r4 root=/dev/hda3



    I did NOT use genkernel for the kernel configuration. Is there something I may have missed during the manual configuration?
    Does anyone know any reasons for why this may still be the case?

  10. #19
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    Quote Originally Posted by brokenspatula
    So, I followed the manual from the beginning, and I am stil having the same problem...

    VFS: Cannot open root device "hda3" or unknown-block(0,0)
    Please append a correct "root=' boot option
    Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)


    grub.conf is:

    default 0
    timeout 30
    splashimage=(hd0,0)/boot/grub/splash.xpm.gz
    title=gentoo 2.6.17-gentoo-r4
    root (hd0,0)
    kernel /boot/kernel-2.6.17-gentoo-r4 root=/dev/hda3



    I did NOT use genkernel for the kernel configuration. Is there something I may have missed during the manual configuration?
    Does anyone know any reasons for why this may still be the case?
    It is saying that either you don't have a /dev/hda3 or it can't read the filesystem (more likely). Make sure you built your filesystem into your kernel and not as modules. Any filesystem you use on should be built into the kernel.

    Linux User #376741
    Code is Poetry

  11. #20
    Just Joined!
    Join Date
    Aug 2006
    Posts
    5
    I've went through the install at least 3 times, and each time I ended up with the same problem.

    I though I built the filesystem into the kernel but I was still getting the same problem. So I tried to build every filesystem into the kernel and that fixed my problem...I'll go back and figure out what I don't need.

    Thanks for all the help

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •