Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
just to let you guys know my boot is /dev/hda1, /dev/hda1 is a swap partition, and root is in my /dev/hda3. so heres my grub.conf: \\\\\\\\\\\\\\\\\\\\\\\\\ \\\\\\ default 0 timeout ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2006
    Posts
    33

    Angry whats wrong with my grub.conf?


    just to let you guys know my boot is /dev/hda1, /dev/hda1 is a swap partition, and root is in my /dev/hda3.

    so heres my grub.conf:
    \\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\ \\\\\\\\\\\
    default 0
    timeout 30
    splashimage=(hd0,0)/boot/grub/splash.xpm.gz
    title=Gentoo Linux 2.6.17
    root (hd0,2)
    kernel /boot/kernel-2.6.17-gentoo-r4 root=/dev/hda3
    \\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\ \\\\\\\\\\\

    when i boot up and my comp goes to grub and i press enter while "Gentoo Linux 2.6.17" is highlighted, i get an error message telling me something like this..

    \\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\ \\\\\\\\\\\
    root (hd0,2)
    kernel /boot/kernel-2.6.17-gentoo-r4 root=/dev/hda3

    (then it has something like Error 15: blah blah blah or something)
    but yeah the error basically tells me the directory doesnt exist or it is wrong or the file is wrong. i am assuming it is referring to the kernel file. i went into knoppix and looked for it, and it is in my /dev/hda1 (would that be hd0,0 in grub?). so yeah whats wrong with my grub.conf??????

  2. #2
    Just Joined!
    Join Date
    Jul 2005
    Location
    Philly, PA
    Posts
    92
    This should offer some help http://www.gentoo.org/doc/en/grub-error-guide.xml
    Scroll down to "Error 15"


    Peace V

  3. #3
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    The problem is that while you see /boot as an extension of /dev/hda3, it's not actually. You need to mount it before it becomes /boot, and GRUB doesn't mount anything.

    Try this:
    Code:
    default 0
    timeout 30
    splashimage=(hd0,0)/boot/grub/splash.xpm.gz
    title=Gentoo Linux 2.6.17
    root (hd0,2)
    kernel (hd0,0)/kernel-2.6.17-gentoo-r4 root=/dev/hda3

  4. #4
    Just Joined!
    Join Date
    Jul 2006
    Posts
    33
    ok now i have this error when i boot into gentoo....

    VFS: Cannot open root device "hda3" or unknown-block(0,0)
    Please append a correct "root=' boot option
    Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)




    my grub.conf now looks like this:


    default 0
    timeout 30
    splashimage=(hd0,0)/boot/grub/splash.xpm.gz
    title=Gentoo Linux 2.6.17
    root (hd0,2)
    kernel (hd0,2)/boot/kernel-2.6.17-gentoo-r4 root=/dev/hda3


    i guess the gentoo gods dont want me to get gentoo...

  5. #5
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    change kernel (hd0,2)/boot/kernel-2.6.17-gentoo-r4 root=/dev/hda3
    to
    kernel (hd0,0)/kernel-2.6.17-gentoo-r4 root=/dev/hda3

    because you have a boot partition, you don't need to add the /boot part in grub.conf for both the kernel and the splashimage.
    Life is complex, it has a real part and an imaginary part.

  6. #6
    Just Joined!
    Join Date
    Jul 2006
    Posts
    33
    that didnt help... same error when i boot

  7. #7
    Just Joined!
    Join Date
    Jul 2006
    Posts
    33
    got past the error when i boot....

    now i have this though....


    *Checking root filesystem
    fsck.ext3: No such file or directory while trying to open /dev/ROOT
    /dev/ROOT:
    The superblock could not be read or does not describe a correct ext2 filesystem. If the device is valid and it really contains an ext2 filesystem (and not swap or ufs or someting else), then the superblock is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck - b 8193 <device>
    *Filesystem could not be fixed



    what the heck does that mean?? i think i forgot to configure something in the kernel, thats how i solved my last problem.

  8. #8
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    What filesystem is your / filesystem? You need to have support for that filesystem COMPILED INTO THE KERNEL (not as a module).

  9. #9
    Just Joined!
    Join Date
    Jul 2006
    Posts
    33
    i have the ext3 filesystem on all my partitions... i have ext2 and ext3 support configured into the kernel not as modules.

  10. #10
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    Quote Originally Posted by jpulumbarit
    got past the error when i boot....

    now i have this though....


    *Checking root filesystem
    fsck.ext3: No such file or directory while trying to open /dev/ROOT
    /dev/ROOT:
    The superblock could not be read or does not describe a correct ext2 filesystem. If the device is valid and it really contains an ext2 filesystem (and not swap or ufs or someting else), then the superblock is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck - b 8193 <device>
    *Filesystem could not be fixed


    what the heck does that mean?? i think i forgot to configure something in the kernel, thats how i solved my last problem.
    You need to correctly edit your /etc/fstab file from the chroot environment.

    You shouldn't have /dev/ROOT there, it should be /dev/hda3 (or whatever your root filesystem is).

    You probably need to go through the install manual again and make sure you did everything it asked, and make sure you understand what it is asking you to do.

    Linux User #376741
    Code is Poetry

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •