Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
ok guys this seems to be the last errors im getting on boot. i get this before it asks me to log in: # Setting up xdm... # /sbin/start-stop daemon: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2006
    Posts
    33

    my final hurdle (i hope) to having gentoo /w kde


    ok guys this seems to be the last errors im getting on boot.

    i get this before it asks me to log in:

    # Setting up xdm...
    # /sbin/start-stop daemon: stat /usr/bin/xdm: No such file or directory
    # ERROR: could not start the Display Manager
    # xdm: no process killed

    then i get this when i run "startx":

    # Failed to load module "nv"
    (for the sake of rewriting all of this.. ) Failed to.... "fbdev", "vesa", "vga", "mouse", and "kbd"
    # Fatal server error: no screens found
    # XIO: fatal IO error 104 (connection reset by peer) on X server ":0.0"
    after 0 requests (0 known processed) with 0 events remaining.

    thanks for the help in advance liek always

  2. #2
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    please post your /etc/X11/xorg.conf file!
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  3. #3
    Just Joined!
    Join Date
    Jul 2006
    Posts
    33
    # /etc/X11/xorg.conf (xorg X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
    # (Type "man /etc/X11/xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    # sudo dpkg-reconfigure -phigh xserver-xorg

    Section "Files"
    FontPath "/usr/share/X11/fonts/misc"
    FontPath "/usr/share/X11/fonts/cyrillic"
    FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
    FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
    FontPath "/usr/share/X11/fonts/Type1"
    FontPath "/usr/share/X11/fonts/100dpi"
    FontPath "/usr/share/X11/fonts/75dpi"
    # path to defoma fonts
    FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    EndSection

    Section "Module"
    Load "i2c"
    Load "bitmap"
    Load "ddc"
    Load "dri"
    Load "extmod"
    Load "freetype"
    Load "glx"
    Load "int10"
    Load "type1"
    Load "vbe"
    EndSection

    Section "InputDevice"
    Identifier "Generic Keyboard"
    Driver "kbd"
    Option "CoreKeyboard"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc104"
    Option "XkbLayout" "us"
    EndSection

    Section "InputDevice"
    Identifier "Configured Mouse"
    Driver "mouse"
    Option "CorePointer"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "ExplorerPS/2"
    Option "ZAxisMapping" "4 5"
    Option "Emulate3Buttons" "true"
    EndSection

    Section "InputDevice"
    Driver "wacom"
    Identifier "stylus"
    Option "Device" "/dev/wacom" # Change to
    # /dev/input/event
    # for USB
    Option "Type" "stylus"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY
    EndSection

    Section "InputDevice"
    Driver "wacom"
    Identifier "eraser"
    Option "Device" "/dev/wacom" # Change to
    # /dev/input/event
    # for USB
    Option "Type" "eraser"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY
    EndSection

    Section "InputDevice"
    Driver "wacom"
    Identifier "cursor"
    Option "Device" "/dev/wacom" # Change to
    # /dev/input/event
    # for USB
    Option "Type" "cursor"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY
    EndSection

    Section "Device"
    Identifier "NVIDIA Corporation NV34 [GeForce FX 5500]"
    Driver "nv"
    BusID "PCI:2:0:0"
    EndSection

    Section "Monitor"
    Identifier "NEC FE991SB"
    Option "DPMS"
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Device "NVIDIA Corporation NV34 [GeForce FX 5500]"
    Monitor "NEC FE991SB"
    DefaultDepth 24
    SubSection "Display"
    Depth 1
    Modes "1600x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 4
    Modes "1600x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1600x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 15
    Modes "1600x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1600x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1600x1200" "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    EndSection

    Section "ServerLayout"
    Identifier "Default Layout"
    Screen "Default Screen"
    InputDevice "Generic Keyboard"
    InputDevice "Configured Mouse"
    InputDevice "stylus" "SendCoreEvents"
    InputDevice "cursor" "SendCoreEvents"
    InputDevice "eraser" "SendCoreEvents"
    EndSection

    Section "DRI"
    Mode 0666
    EndSection






    i have never seen this before or seen anywhere that i have to configure it so if something is not right please dont get on my case too hard

  4. #4
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    And why do you have an xorg.conf from debian?

    Also, make sure you have edited your /etc/rc.conf file to specify which login manager you want.

    Linux User #376741
    Code is Poetry

  5. #5
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144

    Section "Device"
    Identifier "NVIDIA Corporation NV34 [GeForce FX 5500]"
    Driver "nv"
    BusID "PCI:2:0:0"
    EndSection

    Section "Monitor"
    Identifier "NEC FE991SB"
    Option "DPMS"
    EndSection
    you should change these to:

    Code:
    Section "Device"
    Identifier "NVIDIA Corporation NV34 [GeForce FX 5500]"
    Driver "nv"
    #BusID "PCI:2:0:0"
    EndSection
    
    Section "Monitor"
    Identifier "NEC FE991SB"
    Option "DPMS"
    HorizSync "x-x"
    VertRefresh "x-x"
    EndSection
    where the "x-x" are the correct values usually found in your monitor's manual or on google.

    mine are

    50-160
    40-90

    but that is for my monitor which is a IBM CRT. I just put the values down for reference. Placing the wrong values here may have bad consequences for your hardward.

    Also you should be able to install the nvidia proprietary drivers using.

    emerge -va nvidia-drivers

    then change the driver from "nv" to "nvidia"

    and stop glx from loading

    Load "glx" should become # Load "glx"

    you can also use the command: xorgcfg from the command line to create a new xorg.conf file that is a little more streamline instead of this debian one.
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  6. #6
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    Quote Originally Posted by spencerf
    you should change these to:

    Code:
    Section "Device"
    Identifier "NVIDIA Corporation NV34 [GeForce FX 5500]"
    Driver "nv"
    #BusID "PCI:2:0:0"
    EndSection
    
    Section "Monitor"
    Identifier "NEC FE991SB"
    Option "DPMS"
    HorizSync "x-x"
    VertRefresh "x-x"
    EndSection
    where the "x-x" are the correct values usually found in your monitor's manual or on google.

    mine are

    50-160
    40-90

    but that is for my monitor which is a IBM CRT. I just put the values down for reference. Placing the wrong values here may have bad consequences for your hardward.

    Also you should be able to install the nvidia proprietary drivers using.

    emerge -va nvidia-drivers

    then change the driver from "nv" to "nvidia"

    and stop glx from loading

    Load "glx" should become # Load "glx"

    you can also use the command: xorgcfg from the command line to create a new xorg.conf file that is a little more streamline instead of this debian one.
    With the nvidia drivers you want glx loaded. You DON'T want dri loaded though. Comment out dri instead of glx with the nvidia drivers.

    Linux User #376741
    Code is Poetry

  7. #7
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    With the nvidia drivers you want glx loaded. You DON'T want dri loaded though. Comment out dri instead of glx with the nvidia drivers.
    __________________
    woops, my bad haven't looked at my desktop's xorg.conf in a while. Sorry for the misinformation.
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  8. #8
    Just Joined!
    Join Date
    Jul 2006
    Posts
    33
    ehh crap i posted the xorg that shoed up when i ran a ubuntu live cd.....

    but yeah anyways i ran xorgconfig and configured the real one, and i think i have everything right, now i have what seems a minor error....


    (EE) Failed to load module "nvidia" (module does not exist, 0)
    (EE) Failed to load module "kbd" (module does not exist, 0)
    (EE) No drivers availible

    ^thats pretty much all is wrong when i try to "startx". no other problems whatsoever anywhere else that i know of. i will try to get my real xorg.conf up in a few minutes....

  9. #9
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    Did you emerge the nVidia drivers?
    Code:
    emerge nvidia-drivers
    For the kbd issue, do you have this line in your /etc/make.conf?
    Code:
    INPUT_DEVICES="keyboard mouse"
    If not, then put it there. Had it been there originally, kbd would have been installed automatically. Instead, install the driver manually:
    Code:
    emerge xf86-input-keyboard
    If it was there, then that's very strange, and I can only recommend trying it manually anyway. If that doesn't work, let us know.

  10. #10
    Linux Engineer d38dm8nw81k1ng's Avatar
    Join Date
    Mar 2005
    Location
    Newcastle
    Posts
    793
    and also
    Code:
    VIDEO_CARDS="nvidia"
    in /etc/make.conf
    Here's why Linux is easier than Windows:
    Package Managers! Apt-Get and Portage (among others) allow users to install programs MUCH easier than Windows can.
    Hardware Drivers. In SuSE, ALL the hardware is detected and installed automatically! How is this harder than Windows' constant disc changing and rebooting?

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •