Hi folks,

I followed "The GNOME Configuration HOWTO"
http://www.gentoo.org/doc/en/gnome-config.xml

installing Gnome. Steps writen there went though w/o problem until upto;
Code Listing 2.7: Adding hald and avahi-dnsconfd to the default runlevel

On running;
# /etc/init.d/hald start

I failed to find "hald" but "hald.sh" instead. I considered they were the same "sh-script" and hit [ENTER]. Following was displayed on the screen;
Code:
Shunting down the Logical Volume Manager
Shunting down Logical Volume : /dev/vg/usr
Shunting down Logical Volume : /dev/vg/home
Shunting down Logical Volume : /dev/vg/opt
Shunting down Logical Volume : /dev/vg/var
Shunting down Logical Volume : /dev/vg/tmp
Shunting down Volume Group : vg ...
Finished Shutting down the Logical Volume Manager
Remounting remaining file systems readonly
Then my nightmare came again. Some commands can't be found. They were on LV

Continued
# rc-update add hald default
Code:
... file not found
# rc-update add hald.sh default
Code:
... file not found
Then I ran
# vgchange -a y
.... something locked (sorry I can't recall exactly)

I can't proceed further and ran;
# shutdown -r now
text scrolling started ending at - blinking.

Pressed "reset" to restart Gentoo. On booting there was no error/complaint displayed. Gentoo started with login prompted up properly.

Login
# startx
X window started.


Please advise;
1)
Do I need to reinstall Gnome?
(remark: installed "gnome-light")

If YES how to remove Gnome, the unfinished package?


2)
How to overcome the problem mentioned? I must run the command line in question on 2nd installation of Gnome.


Furthermore I forgot mentioning on running;
# rc-update del famd default
(Code Listing 2.6: Switching to gamin)
fam can't be found.


TIA


B.R.
satimis