Find the answer to your Linux question:
Results 1 to 3 of 3
I have followed the Gentoo wiki on setting up XGL. Under the Windowed Mode subsection of the Running XGL section, I (an nVidia user) run: Code: # Xgl :1 -ac ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Mar 2005
    Location
    Minneapolis, MN
    Posts
    112

    XGL Setup Issue?


    I have followed the Gentoo wiki on setting up XGL. Under the Windowed Mode subsection of the Running XGL section, I (an nVidia user) run:

    Code:
    # Xgl :1 -ac -accel glx:pbuffer -accel xv -fp /usr/share/fonts/misc,/usr/share/fonts/other_fonts
    And the standard grey nested X window pops up. Upon following the next step (being a compiz user), I run:

    Code:
    # LD_LIBRARY_PATH=/usr/lib/opengl/xorg-x11/lib/ \
    # DISPLAY=:1 compiz gconf
    This causes my nested window to turn black, freeze and quit rendering. I can just click the X of my window manager, or ctrl+c in the terminal I created it with, to stop it. In fact, I can ctrl+c in the terminal I called compiz with, and it reverts to a grey screen. Nonetheless, it's not getting me anywhere. I am stuck here in the setup process. Any ideas? TIA.
    --Dachnaz [Fuzzy Llama]

  2. #2
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    It may be just related to xnest, that step is just for testing so you can skip it. It may work ...
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  3. #3
    Just Joined!
    Join Date
    Apr 2007
    Posts
    1
    when I write "compiz start" it shows me this:

    compiz. real: Screen 0 on display ":0.0" alredy has a window manager; try using --replace option to replace the current window manager. compiz real: No manageable screens found on display :0.0

    If I write

    "compiz --replace gconf &"

    This causes my current window freeze. I can't click the X of my window, because that tab disappears, and I can't change the current window. The only thig I can do is to restart my computer by clicking ctrl+alt+backspace... please help
    BTW, I have nVidia GForce 5200 FX

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •