Find the answer to your Linux question:
Results 1 to 10 of 10
emerged the nvidia drivers by setting some flags /etc/make.conf, and installing xorg-x11. Copied my xorg.conf from my old Debian etch system and put it in /etc/X11/ issued startx The nvidia ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064

    nvidia drivers


    emerged the nvidia drivers by setting some flags /etc/make.conf, and installing xorg-x11. Copied my xorg.conf from my old Debian etch system and put it in /etc/X11/

    issued startx

    The nvidia logo appeared but glxinfo in xterm (under twm) shows no direct rendering.

    I am a gentoo newbie.. first gentoo installation

    thanks in advance
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  2. #2
    0-1
    0-1 is offline
    Just Joined!
    Join Date
    Apr 2005
    Posts
    7
    you can download nv's drivers here,and install it manually,it's better because you needn't configure your x11
    hope this help

  3. #3
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    http://www.gentoo.org/doc/en/nvidia-guide.xml

    All you need for your nvidia card.

    And in most distributions (not only gentoo) it is best to use the package manager to install the drivers. That way, the package manager can update them when running a system update and there is an update. If you use the nvidia installer, you have to manually keep them up to date.

    Linux User #376741
    Code is Poetry

  4. #4
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    Well, tried to reemerge the nvida drivers but it doesnt work ... Ill go with the installer ..
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  5. #5
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    What exactly doesn't work? If it is just direct rendering, then try this:
    Code:
    eselect opengl set nvidia
    Make sure and have the correct options in your kernel also.

    And btw, the "nvidia-drivers" package in portage is the official nvidia drivers and nvidia-glx. They are just packaged for easy installation and mainenance in portage.

    Remember that you can't have the nvidia framebuffer compiled in and use the nvidia drivers.

    Also, in gentoo it is encouraged to use
    Code:
    /etc/init.d/xdm start | stop | restart
    to start, stop, or restart X.

    Linux User #376741
    Code is Poetry

  6. #6
    Just Joined!
    Join Date
    Jan 2005
    Posts
    48
    Code:
    emerge -av nvidia-drivers
    modprobe nvidia
    lsmod |grep nvidia
    eselect opengl set nvidia
    then go edit the xorg config, i would first run xorgconfig and use a new config rather then the old debian one. and dont use the nvidia's installer, let portage do it, thats why we have portage

    EDIT: make sure you uncomment the glx line in xorg.conf then once in X again run glxgears froma terminal

  7. #7
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    I'll try again with your suggestions
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  8. #8
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    Worked!!

    How can I set it to modprobe nvidia during boot?
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  9. #9
    Linux Engineer d38dm8nw81k1ng's Avatar
    Join Date
    Mar 2005
    Location
    Newcastle
    Posts
    793
    don't bother, X automatically does it when it loads from startx or whatever you're using.
    Here's why Linux is easier than Windows:
    Package Managers! Apt-Get and Portage (among others) allow users to install programs MUCH easier than Windows can.
    Hardware Drivers. In SuSE, ALL the hardware is detected and installed automatically! How is this harder than Windows' constant disc changing and rebooting?

  10. #10
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    That's great thanks
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •