Find the answer to your Linux question:
Results 1 to 4 of 4
Hi! I have gentoo and after I updated the system, it won't boot First kernel steps OK but then : * Starting udev ... * Checking root filesystem ... failed ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2006
    Posts
    2

    at boot (can't open root device /dev/hda6)


    Hi!

    I have gentoo and after I updated the system,
    it won't boot

    First kernel steps OK but then :

    * Starting udev ...

    * Checking root filesystem ...
    failed to open the device /dev/hda6 No such file or directory

    then enter password or press CTRL D

    if i enter the password, i'm logged readonly on my /dev/hda6 partition
    My hard drive is OK if I boot on a liveCD the partition is OK ...

    I checked my fstab, my grub.conf, and tried fsck and everything looks fine and normal....

    please any idea may help....

  2. #2
    Linux Engineer d38dm8nw81k1ng's Avatar
    Join Date
    Mar 2005
    Location
    Newcastle
    Posts
    793
    post your fstab, grub.conf and the output of
    Code:
    fdisk -l
    that's a little L btw
    Here's why Linux is easier than Windows:
    Package Managers! Apt-Get and Portage (among others) allow users to install programs MUCH easier than Windows can.
    Hardware Drivers. In SuSE, ALL the hardware is detected and installed automatically! How is this harder than Windows' constant disc changing and rebooting?

  3. #3
    Just Joined!
    Join Date
    Sep 2006
    Posts
    2
    Hi! thanks for your fast reply...
    /etc/fstab

    # <fs> <mountpoint> <type> <opts> <dump/p$
    # NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
    /dev/hda1 /boot ext2 defaults,noatime 1 2
    /dev/hda6 / reiserfs noatime 0 1
    159.90.9.211:/home /home nfs auto,rw 0 1
    159.90.9.209:/mnt/musica /mnt/musica nfs auto,rw 0 0
    /dev/hda5 none swap sw 0 0
    /dev/cdroms/cdrom0 /mnt/cdrom iso9660 noauto,ro 0 0
    #/dev/fd0 /mnt/floppy auto noauto 0 0

    # NOTE: The next line is critical for boot!
    proc /proc proc defaults 0 0

    # glibc 2.2 and above expects tmpfs to be mounted at /dev/shm for
    # POSIX shared memory (shm_open, shm_unlink).
    # (tmpfs is a dynamically expandable/shrinkable ramdisk, and will
    # use almost no memory if not populated with files)
    shm /dev/shm tmpfs nodev,nosuid,noexec




    Grub .conf

    timeout 30
    default 0
    title Gentoo linux
    root (hd0,0)
    kernel /kernel-2.6.12.5 root=/dev/hda6

    fdisk -l

    Disk /dev/hda: 40.0 GB, 40020664320 bytes
    255 heads, 63 sectors/track, 4865 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/hda1 * 1 12 96358+ 83 Linux
    /dev/hda2 13 4865 38981722+ 5 Extended
    /dev/hda5 13 43 248976 82 Linux swap / Solaris
    /dev/hda6 44 2475 19535008+ 83 Linux
    /dev/hda7 2476 4865 19197643+ 83 Linux

  4. #4
    Linux Engineer d38dm8nw81k1ng's Avatar
    Join Date
    Mar 2005
    Location
    Newcastle
    Posts
    793
    try putting defaults into the <opts> for /dev/hda6 (the bit with noatime on).
    Here's why Linux is easier than Windows:
    Package Managers! Apt-Get and Portage (among others) allow users to install programs MUCH easier than Windows can.
    Hardware Drivers. In SuSE, ALL the hardware is detected and installed automatically! How is this harder than Windows' constant disc changing and rebooting?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •