Find the answer to your Linux question:
Results 1 to 8 of 8
My computer boots fine... then I see some radeon stuff (apparently starting xorg) then my screen turns black. ...doesn't blink.. not out of range or anything -- just solid black. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2006
    Posts
    4

    Xorg -- wtf? please help


    My computer boots fine... then I see some radeon stuff (apparently starting xorg) then my screen turns black.

    ...doesn't blink.. not out of range or anything -- just solid black.

    i'm using an ati radeon x800


    pleeeeeeeeeease help

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    when screen turns black, press Alt+Ctrl+F1 and log in. post the contents of /etc/X11/xorg.cong file.





    casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Oct 2006
    Posts
    4
    That didn't make a difference. it didn't even work, nothing happened.

  4. $spacer_open
    $spacer_close
  5. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    try some other combinations. Alt+Ctrl+F2, F3 etc... if system booted up correctly, then it should display a CLI login prompt.




    casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  6. #5
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    The right key combination should be CTRL-ALT-F1 (you can use any terminals up to 6 so CTRL-ALT-F2 to CTRL-ALT-F6 should also work).

  7. #6
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    I have seen problems with ATI and DVI where you cannot change to the VTs. See if you can boot into runlevel 3 (try typing '3' when grub shows at boot time) and then cehck out the Xorg logs in /var/log.
    Last edited by bigtomrodney; 10-22-2006 at 09:56 PM.

  8. #7
    Linux Engineer psic's Avatar
    Join Date
    Nov 2004
    Location
    Ljubljana, Slovenia
    Posts
    1,205
    Quote Originally Posted by bigtomrodney
    I have seen problesm with ATI and DVI where you cannot change to the VTs. See if you can boot into runlevel 3 (try typing '3' when grub shows at boot time) and then cehck out the Xorg logs in /var/log.
    You can also add this to the boot line: 'softlevel=single', without the quotes, to get to a command line logon.

  9. #8
    Linux Newbie
    Join Date
    Jul 2005
    Posts
    180
    Is this with the proprietary driver or the open source? I sometimes have had problems with the black screen with my radeon card, but not with the open source driver.

    A quick fix just so you can get into X-windows is to run xorgconfig and select either vesa, ati or radeon instead of fglrx for your driver.

    Another thing to do is edit out the cool 3d acceleration options-- dri and glx if you have them enabled, these appear in the xorg.conf file.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •