Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 16 of 16
Try the generic kernel and see if you can boot with that. Just follow the instructions in the handbook for compiling the generic kernel. It includes support for just about ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Newbie
    Join Date
    Jul 2005
    Posts
    180

    Try the generic kernel and see if you can boot with that. Just follow the instructions in the handbook for compiling the generic kernel. It includes support for just about everything, which makes it alot bigger but you would be guaranteed to boot. You can still customize your kernel later by recompiling it.

  2. #12
    Just Joined!
    Join Date
    Oct 2006
    Location
    Kentucky
    Posts
    10
    Hi! thx mahlerfan for your suggestions
    I followed the instructions in the handbook, but I have a problem. In the handbook it says

    Code Listing 17: Copying over the Installation CD kernel config
    (Only do this if you are going to configure a 2.6 kernel)
    # zcat /proc/config.gz > /usr/share/genkernel/x86/kernel-config-2.6

    The thing is, I don't use an installation CD and can't copy the files. Has sb an idea where I can find these?

    thx

  3. #13
    Linux Newbie
    Join Date
    Jul 2005
    Posts
    180
    Oh yeah I did that once, installed by chrooting from another linux. I don't remember exactly what I did but I remember finding this alternative handbook for that kind of install helpful--

    http://www.gentoo.org/doc/en/altinstall.xml

  4. #14
    Just Joined!
    Join Date
    Nov 2006
    Posts
    2
    Quote Originally Posted by TruthSeeker
    Shouldn't your grub.conf kernel boot line say
    kernel /boot/linux-2.6.16-r8 root=/dev/hda3
    instead of
    kernel /boot/linux-2.6.16-r8 root=dev/hda3
    ?
    It needs the slash before dev.
    Keep it as (hd0,0).

    The boot line should say:
    kernel /boot/linux-2.6.16-r8 root=/dev/sda3
    according to your fstab, the real root device is sda3, not hda3, since it is a SCSI/SATA device

  5. #15
    Just Joined!
    Join Date
    Nov 2006
    Posts
    2
    maybeyou configured your kernel with deprecated SATA drivers, the line then must say:
    root=/dev/hde1.
    or you didn't configure the right SATA drivers in your kernel kernel...

    i just had the same problem on my laptop, until i finally found outm that i didn't select the ide-controller drivers...

  6. #16
    Just Joined!
    Join Date
    Jan 2008
    Posts
    10
    Quote Originally Posted by nekrostar View Post
    Hi!
    I just installed gentoo after the construction of the Gentoo Install Handbook and after some problems, I'm done. But now a problem occured when I tried to boot in my new environment...

    my grub.conf:
    ...
    title=Gentoo Linux 2.6.16-r8
    root (hd0,0)
    kernel /boot/linux-2.6.16-r8 root=dev/hda3
    ...

    error during booting:
    VFS: Cannot open root device "ram0" or unknown block (0,0)
    Please append a correct "root=" boot option
    Kernel panic - not syncing: VFS: Unable to mount root fs on unknown block(0,0)

    My hd is SATA and my partitioning scheme is:
    /dev/sda1 boot
    /dev/sda2 Linux swap
    /dev/sda3 root

    I tried several ways and searched the forum(what I'll probably do until I find my fault), but usually I got again the same fault. When I tried
    kernel /boot/linux-2.6.16-gentoo-r8 root(0,2)
    I got another error:
    VFS: Cannot open root device "<NULL>" or unknown-block(8,3)
    Please append a correct "root=" boot option
    Kernel panic - not syncing: VFS: Unable to mount rootfs on unknown block(8,3)
    I faced same problem... What I did...?
    I run Grub command line @ booting
    grub>root (hd0,0)
    grub>kernel /vmlinuz(version) root=/dev/hd0
    (Faced the same problem as above)
    Because I had a raid1 and LVM on it(I realized)
    Then I hit n tried with
    grub>kernel /vmlin...... root/dev/vol00/logvol00
    Then
    grub>kernel /vmlinuz.... root/dev/vol00/logvol01 and so on
    @ One DEVICE my kernel booted properly
    So I must suggest try one by one and @ successful boot add that line in your grub.conf file.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •