Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
Hi! I just installed gentoo after the construction of the Gentoo Install Handbook and after some problems, I'm done. But now a problem occured when I tried to boot in ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2006
    Location
    Kentucky
    Posts
    10

    booting => Kernel panic ; problem with grub.conf


    Hi!
    I just installed gentoo after the construction of the Gentoo Install Handbook and after some problems, I'm done. But now a problem occured when I tried to boot in my new environment...

    my grub.conf:
    ...
    title=Gentoo Linux 2.6.16-r8
    root (hd0,0)
    kernel /boot/linux-2.6.16-r8 root=dev/hda3
    ...

    error during booting:
    VFS: Cannot open root device "ram0" or unknown block (0,0)
    Please append a correct "root=" boot option
    Kernel panic - not syncing: VFS: Unable to mount root fs on unknown block(0,0)

    My hd is SATA and my partitioning scheme is:
    /dev/sda1 boot
    /dev/sda2 Linux swap
    /dev/sda3 root

    I tried several ways and searched the forum(what I'll probably do until I find my fault), but usually I got again the same fault. When I tried
    kernel /boot/linux-2.6.16-gentoo-r8 root(0,2)
    I got another error:
    VFS: Cannot open root device "<NULL>" or unknown-block(8,3)
    Please append a correct "root=" boot option
    Kernel panic - not syncing: VFS: Unable to mount rootfs on unknown block(8,3)

    I tried also like suggested in another thread
    (hd0,2)/kernel-2.6.16-gentoo-r8 root=/dev/hda3
    , gives the first error listed.

    Another confusing thing that I discovered trying to get gentoo working is when I get my kernel src with
    ls -l /usr/src/linux
    it says my source is
    linux-2.6.17-gentoo-r8
    but in /boot is only the file
    linux-2.6.16-gentoo-r8
    and only this works if I put in my kernel options in grub.conf. Has that sth to do with my problem?

    It would be very great if sb could help me, I would be very glad and I'm ready to try a bunch of possibilities more than I did. Please give me some suggestions. Meanwhile I'm looking on the web and if I find sth I let you know.

    thx

  2. #2
    Linux Newbie
    Join Date
    Jul 2005
    Posts
    180
    Is your boot partition in /dev/hda1? I just want to get clear to understand your root entry.

    Anyway I had that problem too when I first installed gentoo. You need to recompile your kernel. Basically your kernel is lacking an important ingredient in understanding your file system so it can mount it.

    It's the file system support. You need pc bios (should already be there but check anyways), you need not only the basic feature for the file system that you're using (reiser, ext3 etc) but the secondary support (I mean the extra features). Also if you haven't done so already include support for the fs's that windows, bsd or anything else on your pc use. Especially if you already put them in your fstab file to be mounted.

    The quickest way would be to compile a generic kernel and then recompile it to be leaner later. Or if you have patient if you add enough of the appropriate fs support you will get it to boot.

  3. #3
    Just Joined!
    Join Date
    Oct 2006
    Location
    Kentucky
    Posts
    10
    Hi!
    my boot is in sda1 because of the SATA, but I read that grub don't care about SATA etc. and so I think hda1 would be right.
    I'm new to gentoo and linux, and I have no idea how to recompile my kernel. And how can I find out if I have pc bios?

    A little bit additional information:
    sda1 boot is ext2 filesystem
    sda3 root is ext3 filesystem

    At the moment gentoo is the only os on my laptop. I got rid of windows xp, after I discovered knoppix live-cd...

    Anyway thx

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie
    Join Date
    Jul 2005
    Posts
    180
    Recompile the same way that you compiled it the first time--

    chroot into your gentoo install from either a live cd or another linux install and then go into /usr/src/linux and run

    Code:
    make menuconfig
    and then go

    Code:
    make
    and
    Code:
    make modules

  6. #5
    Just Joined!
    Join Date
    Oct 2006
    Location
    Kentucky
    Posts
    10
    Hi!
    I recompiled my kernel and configured menuconfig. When I ran the make modules the following error occured:
    CHK include/linux/version.h
    SPLIT include/linux/autoconf.h -> include/config/*
    touch: setting times of 'include/config/MARKER': Function not implemented
    make: ***[include /config/MARKER] Error 1
    When I tried to reboot the same error occured again...
    my fstab:
    /dev/sda1 /boot /ext2 defaults 1 2
    /dev/sda2 none swap sw 0 0
    /dev/sda3 / /ext3 noatime 0 1

    none /proc proc defaults 0 0
    none /dev tmpfs nodev, nosuid, noexec 0 0

    /dev/hda /mnt/cdrom auto noauto, user 0 0
    Maybe that helps ???
    i will keep trying...
    thx

  7. #6
    Just Joined! TruthSeeker's Avatar
    Join Date
    May 2005
    Location
    127.0.0.1
    Posts
    58
    Wait, I don't think this is a kernel problem.

    Shouldn't your grub.conf kernel boot line say
    kernel /boot/linux-2.6.16-r8 root=/dev/hda3
    instead of
    kernel /boot/linux-2.6.16-r8 root=dev/hda3
    ?
    It needs the slash before dev.
    Keep it as (hd0,0).

    About the modules problem: I've always used the command:
    make modules_install
    (not make modules). Try that instead, unless the handbook says otherwise.

    To install a new kernel, you have to do copy the image into /boot yourself, after compiling it. Do this (from /usr/src/linux):
    cp arch/i386/boot/bzImage /boot/linux-2.6.<whatever>
    (assuming you're on x86)
    then add the new kernel to your grub.conf.
    Last edited by TruthSeeker; 11-03-2006 at 01:49 AM. Reason: fixed typo in command

  8. #7
    Just Joined!
    Join Date
    Oct 2006
    Location
    Kentucky
    Posts
    10
    Quote Originally Posted by TruthSeeker
    Wait, I don't think this is a kernel problem.

    Shouldn't your grub.conf kernel boot line say
    kernel /boot/linux-2.6.16-r8 root=/dev/hda3
    instead of
    kernel /boot/linux-2.6.16-r8 root=dev/hda3
    ?
    thx for this suggestion, but I think it's only a type fault I made when I copied it into my browser.
    I'll try again to recompile my kernel... And look again in the handbook...

  9. #8
    Just Joined! TruthSeeker's Avatar
    Join Date
    May 2005
    Location
    127.0.0.1
    Posts
    58
    Hmm, I just noticed something else. The 'root' option in grub is passed to the kernel... so it's a Linux style drive specification. So it should be /dev/sda3, not /dev/hda3

    (actually I haven't used SATA, so I'm assuming you're right that it's /dev/sdaX)

    Here's another common mistake, though I'm not sure it's your problem:
    Make sure any part of the kernel needed for mounting the root filesystem (disk drivers, filesystem support, etc.) is compiled directly into the kernel, not as a module. The kernel can't load any modules until the root filesystem is mounted.

  10. #9
    Just Joined!
    Join Date
    Oct 2006
    Location
    Kentucky
    Posts
    10
    Quote out of Gentoo Linux Documentation, see here

    "Make sure that every driver that is vital to the booting of your system (such as SCSI controller, ...) is compiled in the kernel and not as a module, otherwise your system will not be able to boot completely."

    Can sb please say me how I can check that?
    thx

  11. #10
    Just Joined!
    Join Date
    Oct 2006
    Location
    Kentucky
    Posts
    10
    Quote Originally Posted by TruthSeeker
    Hmm, I just noticed something else. The 'root' option in grub is passed to the kernel... so it's a Linux style drive specification. So it should be /dev/sda3, not /dev/hda3

    (actually I haven't used SATA, so I'm assuming you're right that it's /dev/sdaX)
    I tried that several times, but it's not that... but thx
    And I read that grub makes no difference between SATA, means sda3 or hda3, it doesn't matter, but I'm not sure about that.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •