Find the answer to your Linux question:
Results 1 to 3 of 3
Hey, I'm trying to install X. I've emerged it, along with my ati-drivers, and ran "Xorg -configure". The result is a nasty error. Does anyone know what this could be? ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2006
    Posts
    17

    Xorg -configure returns error.


    Hey,

    I'm trying to install X. I've emerged it, along with my ati-drivers, and ran "Xorg -configure". The result is a nasty error. Does anyone know what this could be? Thanks!

    Code:
    localhost / # Xorg -configure
    _XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
    _XSERVTransOpen: transport open failed for inet6/localhost:0
    _XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6
    
    X Window System Version 7.1.1
    Release Date: 12 May 2006
    X Protocol Version 11, Revision 0, Release 7.1.1
    Build Operating System: UNKNOWN
    Current Operating System: Linux localhost 2.6.18-gentoo-r4 #9 Thu Dec 14 18:11:46 EST 2006 i686
    Build Date: 13 December 2006
            Before reporting problems, check http://wiki.x.org
            to make sure that you have the latest version.
    Module Loader present
    Markers: (--) probed, (**) from config file, (==) default setting,
            (++) from command line, (!!) notice, (II) informational,
            (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Thu Dec 14 23:34:05 2006
    List of video drivers:
            fglrx
    
    Backtrace:
    0: Xorg(xf86SigHandler+0x81) [0x80cc9a1]
    1: [0xb7f09420]
    2: /usr/lib/xorg/modules/drivers/fglrx_drv.so(atiddxProbeMain+0x121) [0xb751b7c1]
    3: Xorg(DoConfigure+0x20b) [0x80bd6ab]
    4: Xorg(InitOutput+0x83a) [0x80a528a]
    5: Xorg(main+0x276) [0x806e506]
    6: /lib/libc.so.6(__libc_start_main+0xdc) [0xb7c9687c]
    7: Xorg(FontFileCompleteXLFD+0xa5) [0x806da71]
    
    Fatal server error:
    Caught signal 11.  Server aborting
    
    Aborted
    localhost / #

  2. #2
    Content Team tylerwylie's Avatar
    Join Date
    Apr 2004
    Posts
    120
    Doesn't look fun, you've modprobed fglrx? What does /var/log/xorg.0.log say?

  3. #3
    Just Joined!
    Join Date
    Jan 2007
    Posts
    1

    i'm no expert but this worked earlier today

    i had the same problem, i'm not quite sure how i ran across the other command xorgconfig just like that instead of as an argument and it worked perfectly. i hope this will work for you too

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •