Find the answer to your Linux question:
Results 1 to 5 of 5
whilst emerging gnome it wants to emerge imagemagick That errors after about 5 minutes on i686-pc-linux-gnu-gcc -L../magick/.libs -lMagick -shared -L/usr/local/lib Magick.o -o blib/arch/auto/Image/Magick/Magick.so \t -lbz2 -lz -lpthread -lm -lpthread /usr/lib/gcc/i686-pc-linux-gnu/4.1.1/../../../../i686-pc-linux-gnu/bin/ld: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    7

    emerge gnome


    whilst emerging gnome it wants to emerge imagemagick

    That errors after about 5 minutes on

    i686-pc-linux-gnu-gcc -L../magick/.libs -lMagick -shared -L/usr/local/lib Magick.o -o blib/arch/auto/Image/Magick/Magick.so \t -lbz2 -lz -lpthread -lm -lpthread

    /usr/lib/gcc/i686-pc-linux-gnu/4.1.1/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lMagick
    collect2: id returned 1 exit status
    make[1]: *** [blib/arch/auto/Image/Magick/Magick.so] Error 1
    make[1]L Leaving directory '/var/tmp/portage/imagemagick-6.3.0.5/work/ImageMagick-6.3.0/PerlMagick'
    make: *** [all-perl] Error 2
    make: *** Waiting for unfinished jobs....

    !!! Error: media-gfx/imagemagick-6.3.0.5 failed.
    Call stack:
    ebuild.sh, line 1546L called dyn_compile
    ebuild.sh line 937: called src_compile
    imagemagick-6.3.0.5.ebuild, line 86: called die

    !!! compile problem


    so far i've tried simply issuing 'emerge imagemagick' and i get the same error - trying to restart emerge gnome also errors in the same place.
    emerging perl and then trying both of the aforementioned emerges also fails (guessed maybe the PerlMagick had something to do with it)

    Imagemagick IRC (freenode) has tried but hasn't come up with anything yet

    I'd really like to use gnome :-\

    Thanks
    JM

  2. #2
    Just Joined!
    Join Date
    Dec 2006
    Location
    Twin Cities, Minnesota, USA
    Posts
    2
    do you need imagemagick? I think there's a dependancy of gnome that has an imagemagick use flag you could unset...

  3. #3
    Just Joined!
    Join Date
    Jan 2007
    Posts
    1
    Just wanted to say that I'm getting the same issue from emerging KDE. Will try a bunch of things and post back if I find a solution.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    Just use
    Code:
    emerge --resume --skipfirst
    to get past that, and then go back and look at the problem after everything else compiles.

    Linux User #376741
    Code is Poetry

  6. #5
    Just Joined!
    Join Date
    Jan 2007
    Posts
    1
    Please see the gentoo forum:
    http://forums.gentoo.org/viewtopic-t...agemagick.html

    For a couple of confirmed-successful fixes to this problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •