Find the answer to your Linux question:
Results 1 to 4 of 4
I'm at wits end trying to get anything working on this new box. According to lspci I have a ATI Radeon M300, I have followed all the tutorials on getting ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2006
    Posts
    5

    ATI Radeon M300 on Dell inspiron 9300 Laptop


    I'm at wits end trying to get anything working on this new box.

    According to lspci I have a ATI Radeon M300, I have followed all the tutorials on getting ATI support working with no luck.

    When I try and emerge x11-drivers/ati-drivers I get:


    Code:
    >>> Emerging (1 of 1) x11-drivers/ati-drivers-8.27.10-r1 to /
     * ati-driver-installer-8.27.10-x86.run MD5 ;-) ...                       [ ok ]
     * ati-driver-installer-8.27.10-x86.run RMD160 ;-) ...                    [ ok ]
     * ati-driver-installer-8.27.10-x86.run SHA1 ;-) ...                      [ ok ]
     * ati-driver-installer-8.27.10-x86.run SHA256 ;-) ...                    [ ok ]
     * ati-driver-installer-8.27.10-x86.run size ;-) ...                      [ ok ]
     * checking ebuild checksums ;-) ...                                      [ ok ]
     * checking auxfile checksums ;-) ...                                     [ ok ]
     * checking miscfile checksums ;-) ...                                    [ ok ]
     * checking ati-driver-installer-8.27.10-x86.run ;-) ...                  [ ok ]
     * Determining the location of the kernel source code
     * Found kernel source directory:
     *     /usr/src/linux
     * Found kernel object directory:
     *     /lib/modules/2.6.18-gentoo-r6/build
     * Found sources for kernel version:
     *     2.6.18-gentoo-r6
     * Checking for MTRR support enabled ...                                  [ ok ]
     * Checking for AGP support enabled ...                                   [ ok ]
     * Checking for DRM support disabled ...                                  [ ok ]
     * X11 implementation is xorg-x11.
    >>> Unpacking source...
     * Unpacking Ati drivers ...                                              [ ok ]
    >>> Source unpacked.
    >>> Compiling source in /var/tmp/portage/ati-drivers-8.27.10-r1 ...
     * Building the DRM module...
    make: Entering directory `/usr/src/linux-2.6.18-gentoo-r6'
      CC [M]  /var/tmp/portage/ati-drivers-8.27.10-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.o
    /var/tmp/portage/ati-drivers-8.27.10-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:233: error: 'UTS_RELEASE' undeclared here (not in a function)
    /var/tmp/portage/ati-drivers-8.27.10-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c: In function 'firegl_stub_open':
    /var/tmp/portage/ati-drivers-8.27.10-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:559: warning: assignment discards qualifiers from pointer target type
    /var/tmp/portage/ati-drivers-8.27.10-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c: In function '__ke_vm_map':
    /var/tmp/portage/ati-drivers-8.27.10-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:3159: error: 'VM_SHM' undeclared (first use in this function)
    /var/tmp/portage/ati-drivers-8.27.10-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:3159: error: (Each undeclared identifier is reported only once
    /var/tmp/portage/ati-drivers-8.27.10-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.c:3159: error: for each function it appears in.)
    make[1]: *** [/var/tmp/portage/ati-drivers-8.27.10-r1/work/common/lib/modules/fglrx/build_mod/firegl_public.o] Error 1
    make: *** [_module_/var/tmp/portage/ati-drivers-8.27.10-r1/work/common/lib/modules/fglrx/build_mod] Error 2
    make: Leaving directory `/usr/src/linux-2.6.18-gentoo-r6'
     * DRM module not built
    >>> Source compiled.
    >>> Test phase [not enabled]: x11-drivers/ati-drivers-8.27.10-r1
    
    >>> Install ati-drivers-8.27.10-r1 into /var/tmp/portage/ati-drivers-8.27.10-r1/image/ category x11-drivers
     * Installing fglrx module
    install: cannot stat `fglrx.ko': No such file or directory
    
    !!! ERROR: x11-drivers/ati-drivers-8.27.10-r1 failed.
    Call stack:
      ebuild.sh, line 1546:   Called dyn_install
      ebuild.sh, line 1020:   Called src_install
      ati-drivers-8.27.10-r1.ebuild, line 205:   Called linux-mod_src_install
      linux-mod.eclass, line 540:   Called die
    
    !!! doins fglrx.ko failed
    !!! If you need support, post the topmost build error, and the call stack if relevant.
    I have tried adding support as a module and as directly compiled.
    When I run modprobe fglrx I get "FATAL: Module fglrx not found"

    I am fairly new to gentoo and would appriciate any help one would give. Please let me know what I can post to help you help me.

    My AIM screen name is phr0zen84, if you contact me and help me solve this I will be sure and post the solution for others to view.

    Thanks

  2. #2
    Just Joined!
    Join Date
    Dec 2006
    Posts
    5

    Solved (poorly)

    So I ended up breaking down and making a full liveCD instead of a min-install cd just to see if gentoo could get X to work from there. Worked fine so I used the console installer to re-install my system. I feel kinda cheap since I was so close to completing the install from the minimal cd. Oh well. I would still like to understand how the install wizard solved this problem so I could try and understand it. If anyone has any insight let me know.


    Thanks anyone who looked at this.

  3. #3
    Just Joined!
    Join Date
    Feb 2007
    Posts
    2

    UTS_RELEASE moved to utsrelease.h

    This page describes the cause for your problem, and a possible solution:

    http://kerneltrap.org/node/7386

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Feb 2007
    Posts
    2

    Try ATI driver version 8.32.5

    Another solution is toi use a later ATI driver that has been updated to find the UTS_RELEASE define in the new location. ATI driver version 8.32.5 appears to work, for one.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •