Find the answer to your Linux question:
Results 1 to 3 of 3
I'm in a bit of a predicament here. I was finally forced to reboot my Gentoo box yesterday after a week because I recompiled my kernel to add loopback device ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2007
    Posts
    2

    gnome-panel crashes gone wild


    I'm in a bit of a predicament here. I was finally forced to reboot my Gentoo box yesterday after a week because I recompiled my kernel to add loopback device support. When it came back up, I logged into Gnome with my primary username, and started to play around with mounting a Mac disk image (.cdr) so I could look at some files. It didn't seem to be working, so I tried to use Nautilus, renaming it to a .iso and using the Extract Here feature (I believe it's part of Archive Manager, but I'm not sure). Shortly after, I started to receive gnome-panel bug report boxes. Simply closing the box let gnome-panel relaunch, but it would crash again immediately. Between crashes, each time the panel would only load the first two of my launcher icons, and sometimes the desktop switcher would be way too large.

    After fighting with that for a while, I restarted X and logged in with another user. This worked fine and I am currently posting from that other user's account. I have since tried to re-emerge gnome-panel, completely scrapped everything that looked like a setting for the trouble user. (~/.gnome, .gnome2, .gnome2_private, .gconf, .gconfd, .nautilus) but in the process seem to have made it worse because now when I try to log in as the user, i simply get a default green desktop and a cursor with no icons and no response to anything. I tried launching a terminal to the display from another terminal, which worked for a while but eventually died off on me too.

    Sorry for the long post, trying to get all the relevant info out there cause I'm really not sure where to go next. Thanks in advance.

  2. #2
    Just Joined!
    Join Date
    Nov 2006
    Posts
    9
    Sometime stuff stays in /tmp, and it screws things up badly. I'd just try removing *everything* pertaining to your user in /tmp (as root, of course), then rebooting.

    If all else fails, back up the data you want, and delete/recreate the user.

  3. #3
    Just Joined!
    Join Date
    Feb 2007
    Posts
    2
    Ah, thanks for the reply. I hadn't thought of /tmp in my purge frenzy. Doing so did get me some more responsiveness from gnome, but the panel still crashes as soon as I get in. :-/ Guess I have to resort to remaking my user.

    Thanks for the assistance.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •