Find the answer to your Linux question:
Results 1 to 3 of 3
Hello there, I've been looking through the man page of mount and a few threads before that, but I did not find any solutions to my problem, which follows : ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2007
    Posts
    2

    Noob problem : can't mount external hdd


    Hello there,

    I've been looking through the man page of mount and a few threads before that, but I did not find any solutions to my problem, which follows :

    I just bought a 120 go Samsung usb hdd, and Gentoo does not seem to be able to recognize it. It's NTFS, and XP finds it without any problem. I've tried fdisk -l, it does not appear.

    what I did until now is mount -t ntfs /dev/sda1 /mnt/removable
    The answer I get is :

    mount: wrong fs type, bad option, bad superblock on /dev/sda,
    missing codepage or other error
    In some cases useful info is found in syslog - try
    dmesg | tail or so

    I hope you'll be able to help me, and sorry if the solution is obvious

    Thx

    Aku

  2. #2
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    You need the ntfs file system enabled in your kernel as a module or built-in. However you won't be able to write to it.

    You can install ntfs-3g for full write support

    emerge -av fuse
    emerge -av ntfs-3g
    modprobe fuse
    mount -t ntfs-3g /dev/sda1 /mnt/removable

    With this I assume you have some decent USE flags in /etc/make.conf

    If you are new to Linux, you shouldn't be using Gentoo, it's a distro for experienced users.
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  3. #3
    Just Joined!
    Join Date
    Feb 2007
    Posts
    2
    The ntfs was not enabled but now it is and it's still not working. By the way, I saw that there was a write option for ntfs in the kernel. So maybe I won't need ntfs-3g. But that's not really the problem right now : I still can't see my hdd.

    I add here the result to dmesg | tail :

    # dmesg | tail
    sd 0:0:0:0: SCSI error: return code = 0x10070000
    end_request: I/O error, dev sda, sector 0
    SQUASHFS error: sb_bread failed reading block 0x0
    SQUASHFS error: unable to read superblock
    NTFS driver 2.1.27 [Flags: R/O MODULE].
    sd 0:0:0:0: SCSI error: return code = 0x10070000
    end_request: I/O error, dev sda, sector 0
    printk: 75 messages suppressed.
    NTFS-fs error (device sda): read_ntfs_boot_sector(): Unable to read primary boot sector.
    NTFS-fs error (device sda): read_ntfs_boot_sector(): Mount option errors=recover not used. Aborting without trying to recover.
    And yes, I am new to Linux, but I did not really choose Gentoo, some informatician friends of mine put it on my computer when I asked for a nice Linux But I like challenges, so I'll try to go on with it for a while.

    thx for your help

    Aku

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •