Find the answer to your Linux question:
Results 1 to 3 of 3
Hi, about 1 year ago i used gentoo alot, when i bought my new pc it was windows for me, a few days ago i tought, hmm lets try linux ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2007
    Posts
    1

    sound card/alsa problem


    Hi, about 1 year ago i used gentoo alot, when i bought my new pc it was windows for me, a few days ago i tought, hmm lets try linux again.

    so there i was, installed gentoo, kde, brings up old memory's

    installed alsa, perfect, sound works.... until.... i rebooted

    at the moment i rebooted, sound gone and when i started alsamixer it gave the following error

    "function snd_ctl_open failed for default: No such device"

    what could it be that couses this problem? ith ad sound before i emerged alsa, with alsa, but after reboot

  2. #2
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    have you run the the

    alsaconf

    command as root?
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  3. #3
    Keyboard Cowboy
    Join Date
    Jan 2007
    Posts
    5
    ya spencerf is right. You need to run alsaconf, as root, and at the end make sure to say yes to have it save the configuration to the modules.conf. It seems that when you rebooted it didn't load the driver for your card. Alsaconf can configure your modules.conf to load it for you. If it still doesn't work, you may have to manually check and edit your modules.conf to add what you need. And at the end of that if it still doesn't work (unlikely) you may have to write a init script to load the module for you, before alsa is loaded.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •