Find the answer to your Linux question:
Results 1 to 3 of 3
So, I've finally got Gentoo on my system, somehow. Anyway, I booted up, and Grub is all messed up. It doesn't appear, so luckily I remembered where my other partitions ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User
    Join Date
    Aug 2005
    Posts
    341

    GRUB issues


    So, I've finally got Gentoo on my system, somehow. Anyway, I booted up, and Grub is all messed up. It doesn't appear, so luckily I remembered where my other partitions are on the list so I can boot Ubuntu or Windows. When I do try to load Gentoo, the screen has crap strewn all over it making it impossible to see the commandline deal I'm getting, so I don't know what's going on making it impossible for me to boot into Gentoo. I suspect it might be the bootsplash, but I've got a good gfx card, so I don't see why that would be the problem. Regardless, i can't get into gentoo to change the grub.conf, so I'm lost.

    How can I fix this, or should i just delete the partition and re-start the process?

  2. #2
    Linux Newbie
    Join Date
    Jan 2007
    Posts
    110
    Try restore Grub.

    You can do it with Ubuntu. Say if the Gentoo's partition, mostly /boot, has Grub and it is /dev/hda6 then it will be known to Grub as the 6th partition of the 1st disk. Since Grub counts from 0 so it will be known as (hd0,5).

    In Ubuntu just invoke a Grub shell, declare the root partition that has Grub and do a setup to put Grub in the MBR.

    Code:
    sudo grub
    root (hd0,5)
    setup (hd0)
    quit
    reboot
    You can use Ubuntu to edit Grub's /boot/grub/menu.lst by mounting Gentto's partition that has /boot inside.

    If /dev/hda6 above applies then the commands in Ubuntu are just
    Code:
    sudo mkdir /mnt/hda6
    mount /dev/hda6 /mnt/hda6
    vi /mnt/hda6/boot/grub/menu.lst

  3. #3
    Linux User
    Join Date
    Aug 2005
    Posts
    341
    OK, so the story so far:

    I got the bootloader working properly. I can't remember how I did, though, but that brings me to my next anecdote. This morning before class I tried what you said, and added a few lines here and there to my fstab and mtab and the grub files. Lo and behold, the grub menu appeared, but when I booted into Gentoo, it was/is purely command line. This most likely is because I did not specify any gnome or kde, only Xsession support. This is because I want fluxbox on gentoo. But I'll make a newe thread for that. anyway, So I reboot after seeing the sorry state of gentoo. I then go to boot into Ubuntu again. It's all going fine and dandy until it tries to check for the root file system or whatever - then it crashes. A nice command line comes up and I'm sittin there. ****. I realized that maybe ****ing with my computer wasn't such a good idea, given that I've got a programming assignment due in a few days which is on the laptop. By now, it's time for class, so I have to leave my computer a sitting duck in its sorry state.

    When I got back from class, stomach full of a yummy breakfast bacon n' egger-like deal, I boot back into Gentoo to try and access the files in there. Unfortunately, it's telling me it's a read-only filesystem at the moment. ****.

    So I boot into Ubuntu and notice the error message and the command it gives me to gain access to the command line. I muck about with that, use the commands you gave me above from memory, and gain access to gentoo. Here, I double check my files, change stuff, I think, stay in Ubunutu, change a few other things, and reboot and cross my fingers. Somehow it worked, except that Gentoo is not in the state I want it to be in. So that's my next project. :P

    So my experience was a scary one, mostly because I didn't want to have my assignment stuck on my laptop and not get handed in. But at the end of the day (in the span of about an hour or so of fiddling), I got it working, so that final experience of seeing Ubuntu load again was well worth it (kinda). I've got a morbid sense of fun. As my friends play World of Warcraft and MMORPGs, I sit and break my laptop, curse myself for doing so, then somehow fix it again. The lows of the lows, but countered by the highs of the high.

    Thanks for the help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •