Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
Here are a few issues I'll put out right now so you get a feel for what I'm looking for help-wise: 1. When I boot gentoo, it's read-only. I want ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User
    Join Date
    Aug 2005
    Posts
    341

    Gentoo installed - but it's only commandline read-only


    Here are a few issues I'll put out right now so you get a feel for what I'm looking for help-wise:

    1. When I boot gentoo, it's read-only. I want this to change.

    2. If I uncomment the splash-screen option in grub's menu.lst, the grub menu does not appear on bootup (and I have to "guess" which OS I'm going to load), and if I boot into gentoo like this, gentoo's command line has junk covering it, making it impossible to read.

    3. And mainly, Gentoo is currently command-line only. How can I install fluxbox onto it to have a graphical interface?

    Now for some explaining:::

    I have two hard drives (sda, sdb). On the first, Windows resides with another NTFS partition to hold some DVDs of mine. On the second is the following (SATA drives btw).


    Code:
    Disk /dev/sdb: 100.0 GB, 100030242816 bytes
    255 heads, 63 sectors/track, 12161 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sdb1   *           1        4717    37889271   83  Linux
    /dev/sdb2   *        4718        4750      265072+  83  Linux
    /dev/sdb3            4751        5263     4120672+  82  Linux swap / Solaris
    /dev/sdb4            5264       12161    55408185   83  Linux
    The first two, sdb1, sdb2, are Ubuntu boot (ubuntu is actually entirely on one partition) and Gentoo boot respectively. sdb3 is swap, and sdb4 is Gentoo's root.

    Currently when I boot my computer, the menu.lst in Gentoo's boot partition is loaded. But since I've become confused with all these files, I'm gonna list the stuff from both Linux systems:

    UBUNTU:

    Here are the contents of my fstab in Ubuntu

    Code:
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point>   <type>  <options>                    <dump>  <p$proc            /proc           proc    defaults                       0       0
    /dev/sdb1       /               reiserfs notail                        0       1/dev/sdb2       none            swap    sw                             0       0
    /dev/sdb3       /boot           ext2    defaults, noatime              0       2/dev/sdb4       /               ext3    noatime                        0       2
    /dev/sda1       /media/Windows  ntfs  nls=utf8,umask=0222              0       0/dev/sda2       /media/fat32 vfat users,defaults,umask=000             0       0
    /dev/cdrom      /media/cdrom    auto    noauto,user                    0       0/dev/hda        /media/cdrom0           udf,iso9660 user,noauto        0       0
    And here are the contents of mtab in Ubuntu:

    Code:
    /dev/sdb4 / ext3 rw,noatime 0 0
    proc /proc proc rw 0 0
    /sys /sys sysfs rw 0 0
    varrun /var/run tmpfs rw 0 0
    varlock /var/lock tmpfs rw 0 0
    procbususb /proc/bus/usb usbfs rw 0 0
    udev /dev tmpfs rw 0 0
    devpts /dev/pts devpts rw,gid=5,mode=620 0 0
    devshm /dev/shm tmpfs rw 0 0
    lrm /lib/modules/2.6.15-27-386/volatile tmpfs rw 0 0
    /dev/sda1 /media/Windows ntfs rw,nls=utf8,umask=0222 0 0
    And here are the contents of grub's menu.lst in Ubuntu:

    Code:
    ## default num
    # Set the default entry to the entry number NUM. Numbering starts from 0, and
    # the entry number 0 is the default if the command is not used.
    #
    default         0
    
    ## timeout sec
    # Set a timeout, in SEC seconds, before automatically booting the default entry
    # (normally the first entry defined).
    timeout         10
    
    title           Ubuntu, kernel 2.6.15-27-386
    root            (hd1,0)
    kernel          /boot/vmlinuz-2.6.15-27-386 root=/dev/sdb1 ro quiet splash
    initrd          /boot/initrd.img-2.6.15-27-386
    savedefault
    boot
    
    title           Ubuntu, kernel 2.6.15-27-386 (recovery mode)
    root            (hd1,0)
    kernel          /boot/vmlinuz-2.6.15-27-386 root=/dev/sdb1 ro single
    initrd          /boot/initrd.img-2.6.15-27-386
    boot
    
    title           Ubuntu, kernel 2.6.15-26-386
    root            (hd1,0)
    kernel          /boot/vmlinuz-2.6.15-26-386 root=/dev/sdb1 ro quiet splash
    initrd          /boot/initrd.img-2.6.15-26-386
    savedefault
    boot
    
    title           Ubuntu, kernel 2.6.15-26-386 (recovery mode)
    root            (hd1,0)
    kernel          /boot/vmlinuz-2.6.15-26-386 root=/dev/sdb1 ro single
    initrd          /boot/initrd.img-2.6.15-26-386
    boot
    
    title           Ubuntu, memtest86+
    root            (hd1,0)
    kernel          /boot/memtest86+.bin
    boot
    
    ### END DEBIAN AUTOMAGIC KERNELS LIST
    
    # This is a divider, added to separate the menu items below from the Debian
    # ones.
    title           Other operating systems:
    root
    
    
    # This entry automatically added by the Debian installer for a non-linux OS
    # on /dev/sda1
    title           Windows XP Media Center Edition
    root            (hd0,0)
    savedefault
    makeactive
    chainloader     +1
    ----------------------------------------------------------------------------------------------------

    GENTOO:

    Here are the contents of my grub.lst. PLEASE NOTE, IF THE SPLASH-SCREEN OPTION IS UNCOMMENTED, THE BOOTLOADER DOES NOT APPEAR, AND GENTOO'S COMMANDLINE HAS CRAP ALL OVER IT MAKING IT UNREADABLE. I don't know why this is.....

    Also, note that this is the only relevant file I could get access to through Ubuntu using the following commands to mount Gentoo:

    sudo mkdir /mnt/sdb2
    mount /dev/sdb2 /mnt/sdb2

    Anyway...

    Code:
    # Nice, fat splash-image to spice things up :)
    # splashimage=(hd0,0)/boot/grub/splash.xpm.gz
    
    title            Gentoo Linux 2.6.19-r5
    root             (hd1,1)
    kernel           /boot/kernel-2.6.19-gentoo-r5 root=/dev/sdb4
    
    title            Gentoo Linux 2.6.19-r5 (rescue)
    root             (hd1,1)
    kernel           /boot/kernel-2.6.19-gentoo-r5 root=/dev/sdb4
    init             /bin/bb
    
    title           Ubuntu, kernel 2.6.15-27-386
    root            (hd1,0)
    kernel          /boot/vmlinuz-2.6.15-27-386 root=/dev/sdb1 ro quiet splash
    initrd          /boot/initrd.img-2.6.15-27-386
    savedefault
    boot
    
    title           Windows XP Media Center Edition
    root            (hd0,0)
    savedefault
    makeactive
    chainloader     +1

  2. #2
    Just Joined! TruthSeeker's Avatar
    Join Date
    May 2005
    Location
    127.0.0.1
    Posts
    58
    If the filesystem is readonly, it's most likely a problem in your /etc/fstab in gentoo. Please post that.

    I think you're confusing yourself with all the different /boot's. You have a partition, /dev/sdb3, which appears to be Ubuntu's boot, but Gentoo's /boot is part of the fs on /dev/sdb4, yes? Each distro needs it's own /boot to put its kernels in, but only one of them can control GRUB. Either add an entry for Gentoo in ubuntu's /boot/grub/menu.lst and configure grub from there, or add ubunto to Gentoo's /boot/grub/grub.conf and configure it from Gentoo.

    It looks like gentoo is trying to fetch the bootsplash image from the windows partition try changing the line to "splashimage=(hd1,3)/boot/grub/splash.xpm.gz"

    Graphics wise, have you installed and configured xorg? If so, I'd recommend installing GDM as the easiest way to manage X sessions. Then just install fluxbox and select it in GDM's session menu.

    If you haven't installed xorg, you must have missed the link at the end of the gentoo manual about desktops. Basically you'll emerge xorg-x11 then do some configuring.

  3. #3
    Linux User
    Join Date
    Aug 2005
    Posts
    341
    Quote Originally Posted by TruthSeeker
    If the filesystem is readonly, it's most likely a problem in your /etc/fstab in gentoo. Please post that.

    Code:
    # /etc/fstab: static file system information.
    # noatime turns off atimes for increased performance (atimes normally aren't 
    # needed; notail increases performance of ReiserFS (at the expense of storage 
    # efficiency).  It's safe to drop the noatime options if you want and to 
    # switch between notail / tail freely.
    # The root filesystem should have a pass number of either 0 or 1.
    # All other filesystems should have a pass number of 0 or greater than 1.
    # See the manpage fstab(5) for more information.
    # <fs>			<mountpoint>	<type>		<opts>		<dump/pass>
    
    /dev/sdb1       /               reiserfs notail         	               0 1
    /dev/sdb2	/boot		ext2    defaults,noatime  	               1 2
    /dev/sdb3       none            swap    sw  		                       0 0
    /dev/sdb4	/		ext3    noatime	 	               0 1
    
    /dev/sda1       /media/Windows 	ntfs  nls=utf8,umask=0222              0 0
    /dev/sda2       /media/fat32 vfat users,defaults,umask=000    	               0 0
    
    /dev/cdrom      /media/cdrom    auto    noauto,user                            0 0
    /dev/hda        /media/cdrom0   	udf,iso9660 user,noauto                0 0
    
    /dev/cdroms/cdrom0	/mnt/cdrom	iso9660		noauto,ro	       0 0
    
    # NOTE: The next line is critical for boot!
    proc			/proc		proc		defaults	       0 0
    
    # glibc 2.2 and above expects tmpfs to be mounted at /dev/shm for 
    # POSIX shared memory (shm_open, shm_unlink).
    # (tmpfs is a dynamically expandable/shrinkable ramdisk, and will
    #  use almost no memory if not populated with files)
    shm			/dev/shm	tmpfs		nodev,nosuid,noexec	0 0
    I think you're confusing yourself with all the different /boot's. You have a partition, /dev/sdb3, which appears to be Ubuntu's boot, but Gentoo's /boot is part of the fs on /dev/sdb4, yes?

    NO. sdb1 is indeed Ubuntu in it's entirety. When I installed Ubuntu, it all went on one partition, and I had a swap partition. That was it. I subsequently made sdb3 the boot partition for gentoo and sdb4 the / directory for gentoo (by / I am assuming everything else except boot, as suggested by the manual).
    So there's my fstab. Basically, I'm guessing the best first step is to get gentoo writeable since I can't emerge anything anyway unless it's writeable.

  4. #4
    Just Joined! TruthSeeker's Avatar
    Join Date
    May 2005
    Location
    127.0.0.1
    Posts
    58
    Well if sdb1 is your ubuntu partition, you shouldn't be trying to mount it as / in gentoo. Either get rid of that line in fstab, or change the mount point to /media/ubuntu or something like that. Also it looks like you have sdb2 (swap) and sdb3 (/boot) switched. To fix it you'll need write access to the gentoo partition, which you can do from Ubuntu like this:

    mkdir /media/gentoo (if necessary)
    mount -t ext3 /dev/sdb4 /media/gentoo

    Also remember that GRUB is only controlled by ONE distro's /boot/grub/menu.lst (or /boot/grub/grub.conf). It doesn't really matter which you choose. Gentoo might be a bit nicer since it has its own boot partition, but on the other hand Ubuntu is working right now. Just choose one and stick with it.

    Whichever you choose, your menu.lst entries should look something like this:
    Code:
    title           Ubuntu
    root            (hd1,0)
    kernel          /boot/vmlinuz-2.6.15-27-386 root=/dev/sdb1 ro quiet splash
    initrd          /boot/initrd.img-2.6.15-27-386
    savedefault
    boot
    
    title            Gentoo
    root             (hd1,2)    <== note this means /dev/sdb3, /boot, where your kernel is
    kernel           /boot/kernel-2.6.19-gentoo-r5 root=/dev/sdb4
    of course add back in the rescue kernels and such if you want.

    Ask if I said something you don't understand.
    Good luck.

  5. #5
    Linux User
    Join Date
    Aug 2005
    Posts
    341
    Oooooooooppppps.... my bad.... In my post I put a big NO and said that sdb1 was Ubuntu, sdb2 was swap, and 3 was gentoo's boot and 4 was gentoo's /.

    The only thing I'll correct myself on there is, like my file printout shows, the sdb1 is Ubuntu in its entirety, sdb2 is Gentoo's boot (not swap, as I had said), sdb3 is swap, and sdb4 is Gentoo's /.

    Anyway, I've changed a few things real quick, and Gentoo is now writeable (I think anyway. I didn't actually test if I could make a file, but it worked much better than before). However, either my internet connection isn't set up right or something else is wrong because when I "emerge xorg-x11" the deal fails because it couldn't connect to whatever website it was supposed to. So basically right now I'm wanting to get a GUI up, so is there any way to do some stuff in Ubuntu (where internet works on my laptop these days) and just copy stuff over to gentoo so I don't need internet access?

    A funny little anecdote: Strangely, in Windows, Internet Explorer AND Firefox do not work, and yet I can connect to a university hub and limewire and download from those off the internet (perhaps the hub is not internet-based, I'm not sure, but the fact that I can d/l off the internet from limewire and yet not access browsers strikes me as strange). However i am in luck, as firefox works like a charm (minus flash for YouTube etc) in Ubuntu.

  6. #6
    Just Joined!
    Join Date
    Mar 2007
    Posts
    5
    Quote Originally Posted by GivePeaceAChance
    However, either my internet connection isn't set up right or something else is wrong because when I "emerge xorg-x11" the deal fails because it couldn't connect to whatever website it was supposed to. So basically right now I'm wanting to get a GUI up, so is there any way to do some stuff in Ubuntu (where internet works on my laptop these days) and just copy stuff over to Gentoo so I don't need internet access?
    Of course:

    From Ubuntu as root:

    mount /dev/sdb4 /media/gentoo
    mount /dev/sdb2 /media/gentoo/boot
    mount -t proc none /media/gentoo/proc
    mount -o bind /dev /media/gentoo/dev
    chroot /media/gentoo/ /bin/bash
    emerge --sync
    emerge --fetchonly -NuD fluxbox mozilla-firefox
    exit

    Now reboot into Gentoo and run:

    emerge -NuD fluxbox mozilla-firefox

    You could also run the install while in the chroot environment if you like but best to just boot into Gentoo first.

  7. #7
    Linux User
    Join Date
    Aug 2005
    Posts
    341
    So i tried what you said both in gentoo and chroot, but to no avail, I get a lot of stuff like:

    Code:
    >>> Downloading 'http://distro.ibiblio.org/pub/linux/distributions/gentoo/distfiles/gnuconfig-20060702.tar.bz2'
    --07:16:15--  http://distro.ibiblio.org/pub/linux/distributions/gentoo/distfiles/gnuconfig-20060702.tar.bz2
               => `/usr/portage/distfiles/gnuconfig-20060702.tar.bz2'
    Resolving distro.ibiblio.org... failed: Temporary failure in name resolution.
    >>> Downloading 'http://ftp.gentoo.or.kr/distfiles/gnuconfig-20060702.tar.bz2'
    --07:16:15--  http://ftp.gentoo.or.kr/distfiles/gnuconfig-20060702.tar.bz2
               => `/usr/portage/distfiles/gnuconfig-20060702.tar.bz2'
    Resolving ftp.gentoo.or.kr... failed: Temporary failure in name resolution.
    !!! Couldn't download 'gnuconfig-20060702.tar.bz2'. Aborting.
    Basically, it fails to connect to the websites. Now that i think of it, I am not permitted to connect directly to ftp servers or the like from my university connection, so I'd have to go elsewhere perhaps. Could this be the problem? Would a hotspot at a starbucks or something fix that (free me from the confines of the university's security measures)?

  8. #8
    Just Joined!
    Join Date
    Mar 2007
    Posts
    5
    You can set the mirrors portage tries to download from by adding in /etc/make.conf
    GENTOO_MIRRORS="http://gentoo.osuosl.org/"
    You can add more than one, just leave a space in between.
    But from the log you posted it looks like it also failed to download from a http server as well. Going to a wireless hot spot might be a good idea. This could also be dns related, try putting
    GENTOO_MIRRORS="http://64.50.236.52"
    its the same site as gentoo.osuosl.org.

    Of course you can always download the packages manually by navigating out to one of those mirrors and going into the distfiles directory and downloading the files into /usr/portage/distfiles/

  9. #9
    Linux User
    Join Date
    Aug 2005
    Posts
    341
    So if I were to download it manually, since a) Gentoo doesn't currently like my wireless, and b) my wired connection isn't totally security-free, what files do I actually have to download? (And perhaps from where do I download them?)

  10. #10
    Linux User
    Join Date
    Aug 2005
    Posts
    341
    Any ideas?

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •