Find the answer to your Linux question:
Results 1 to 8 of 8
I think I am running Gentoo though I have a vanilla kernel. Whenever I boot up my computer, it starts ath0 and eth0 (the wireless card and the ethernet interface). ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2006
    Posts
    57

    How to stop eth0 interface on boot before dhcpcd lease


    I think I am running Gentoo though I have a vanilla kernel.

    Whenever I boot up my computer, it starts ath0 and eth0 (the wireless card and the ethernet interface). How do I stop the eth0 from starting? Basically I want to do "ifconfig eth0 down" at boot before it starts connecting to anything automatically. I tried rc-update del net.eth0 default or whatever, and there are no net eth0 files in /etc/conf.d. I dunno about the files in /etc/init.d/net.ath0 and /etc/init.d/net.eth0 and /etc/init.d/net.lo. Those are pretty long files. But I want to keep the ath0 up.

    So, how would I go about doing this?

    Thanks in advance.

  2. #2
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    Have you tried rc-update del net.eth0 ?

    /etc/init.d/net.*th0 are init scripts used during boot, you can change them to customize booting.
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  3. #3
    Just Joined!
    Join Date
    Nov 2006
    Posts
    57
    I did do rc-update del net.eth0. I wrote ath0 in my original post by accident. I want to enable ath0 but disable eth0.

    I'm in the I have no /etc/init.d/net.eth0 file, but it's long and I have no idea what all of it means. I just installed this a few days ago.

  4. #4
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    eth0 will be hotplugged by udev, but there is a way to stop this.

    You need to edit /etc/conf.d/rc and look for this:
    Code:
    RC_PLUG_SERVICES=""
    and add this in the quotes:
    Code:
    !net.eth0
    so that it looks like this:
    Code:
    RC_PLUG_SERVICES="!net.eth0"
    You can do that for all of the interfaces that you don't want loaded. That file is very well documented, so please read carefully.

    To get net.ath0 back, type this:
    Code:
    rc-update add net.ath0 default
    rc-update del net.eth0 default
    If you deleted your net.ath0 file in /etc/init.d/, here is the way to get it back:
    Code:
    ln -s /etc/init.d/net.lo /etc/init.d/net.ath0

    Linux User #376741
    Code is Poetry

  5. #5
    Just Joined!
    Join Date
    Nov 2006
    Posts
    57
    Thanks man. You're awesome. Cool

  6. #6
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    You are welcome. I am just here to help.

    Linux User #376741
    Code is Poetry

  7. #7
    Just Joined!
    Join Date
    Feb 2007
    Posts
    4
    awsome thanks this one has had me stumped for a little while, tried everything from patches from bugzilla to looking at rewriting the driver. Its always something simple.

  8. #8
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    Quote Originally Posted by sentralorigin
    I'm in the I have no /etc/init.d/net.eth0 file, but it's long and I have no idea what all of it means. I just installed this a few days ago.

    You will probably find that this file is a symlink to net.lo try running:

    Code:
    ls -FGg /etc/init.d/net.eth0
    It should show something like:

    net.eth0 -> net.lo
    at the end of the returned line. If this is the case, it is just a symlink to the net.lo file and can be deleted. If it needs to be recreated, then you can do so with:

    Code:
    ln -s net.lo net.eth0
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •