Find the answer to your Linux question:
Results 1 to 5 of 5
hi, iīm reinstall my gentoo. i have merged Xorg and now i want to merge KDE. but by installing ebulid x11-libs/qt-4.2.2 it writes me this: Code: /usr/include/X11/extensions/Xrandr.h:299: error: expected ?,? ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2007
    Location
    Czech republik
    Posts
    4

    error by installing QT


    hi,
    iīm reinstall my gentoo. i have merged Xorg and now i want to merge KDE. but by installing ebulid x11-libs/qt-4.2.2 it writes me this:

    Code:
    /usr/include/X11/extensions/Xrandr.h:299: error: expected ?,? or ?...? before ?delete?
    make: *** [xrandr.o] Error 1
    
    !!! ERROR: x11-libs/qt-4.2.2 failed.
    Call stack:
      ebuild.sh, line 1539:   Called dyn_compile
      ebuild.sh, line 939:   Called src_compile
      qt-4.2.2.ebuild, line 199:   Called die
    
    !!! (no error message)
    !!! If you need support, post the topmost build error, and the call stack if relevant.
    i tried find it on google but nothing (if i donīt count russian links ).

    can you help me with this problem?
    thank you

  2. #2
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    I am having this same problem. When I find a solution, I will post back, and I will find a solution quickly, because this is a new install on my laptop, and I have to have it installed.

    I will post back soon.

    In the meantime, you can always run a "revdep-rebuild" and then update your system just in case.

    Linux User #376741
    Code is Poetry

  3. #3
    Just Joined!
    Join Date
    Feb 2007
    Location
    Czech republik
    Posts
    4
    Quote Originally Posted by gruven
    I am having this same problem. When I find a solution, I will post back, and I will find a solution quickly, because this is a new install on my laptop, and I have to have it installed.

    I will post back soon.

    In the meantime, you can always run a "revdep-rebuild" and then update your system just in case.
    it will be greate if you post me the solution
    # revdep-rebuild doeasnīt help me.

    so if you have some time left (and desire too ) for find the solution i will be very pleasure

  4. #4
    Just Joined!
    Join Date
    Feb 2007
    Location
    Czech republik
    Posts
    4
    i found http://bugs.gentoo.org/show_bug.cgi?id=167714. i have changed Xrandr.h and have updated libXrandr and QT is being merged

    if it work fine i will write tomorrow

  5. #5
    Just Joined!
    Join Date
    Feb 2007
    Location
    Czech republik
    Posts
    4
    Quote Originally Posted by waldauf
    i found http://bugs.gentoo.org/show_bug.cgi?id=167714. i have changed Xrandr.h and have updated libXrandr and QT is being merged

    if it work fine i will write tomorrow
    now i have emerged QT which is great but i have next problem. i want to emerge ebulid gd and system reports this error (which i canīt find with google):

    Code:
    tar: Read 5632 bytes from -
    tar: A lone zero block at 7351
    /usr/lib32/libjpeg.so: could not read symbols: File in wrong format
    collect2: ld returned 1 exit status
    make[2]: *** [libgd.la] Error 1
    make[1]: *** [all-recursive] Error 1
    make: *** [all] Error 2
    
    !!! ERROR: media-libs/gd-2.0.34 failed.
    Call stack:
      ebuild.sh, line 1539:   Called dyn_compile
      ebuild.sh, line 939:   Called src_compile
      gd-2.0.34.ebuild, line 28:   Called die
    
    !!! (no error message)
    !!! If you need support, post the topmost build error, and the call stack if relevant.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •