Find the answer to your Linux question:
Results 1 to 9 of 9
I just installed gentoo and I have a few errors to deal with still one of my concerns at the moment is when I start up gentoo I get this ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2007
    Posts
    20

    wrong fs type, /dev/sbd1, shm


    I just installed gentoo and I have a few errors to deal with still one of my concerns at the moment is when I start up gentoo I get this error after
    *mounting local filesystems
    mount: wrong fs type, bad option, bad superblock on /dev/sdb1, missing codepage or other error
    In some cases useful in syslog - try dmesg | tail or so
    I also get the same error but replace /dev/sdb1 with shm
    Any ideas what the problem is??
    Thanks

  2. #2
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    Well, I need more info

    Did you create a file system already?
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  3. #3
    Just Joined!
    Join Date
    Feb 2007
    Posts
    20
    I think so...I finished the handbook through step 10 and booted into linux and thats the error I've been getting for a while now. I was trying to resolve a networking/internet error so I let this one be for a while.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    Sorry, didn't read your post completely, try a fsck
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  6. #5
    Just Joined!
    Join Date
    Feb 2007
    Posts
    20
    well I did
    fsck -n /dev/sdb1 and it came back with no errors and it said it was clean
    fsck -n /dev/shm gave me some kinda error: fsck.tmpfs: not found
    fsck -n /dev/sbd3 gave me warnings about it being mounted and some about miscounted free space and inodes
    ...I'm not really too sure about how to use fsck as this is my first time with linux so I'm quite newbish

  7. #6
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    Could you please post your /etc/fstab so that we can see what is in it?

    Linux User #376741
    Code is Poetry

  8. #7
    Just Joined!
    Join Date
    Feb 2007
    Posts
    20
    sure
    Code:
    /dev/sdb1     /boot     ext2     default,noatime 1 2
    /dev/sdb3     /         ext3     noatime         0 1
    /dev/sdb2     none      swap     sw              0 0
    
    /dev/cdroms/cdrom0  /mnt/cdrom auto   noauto,user 0 0
    /dev/cdroms/cdrom1  /mnt/cdrom auto   noauto,user 0 0
    /dev/fd0            /mnt/floppy auto  noauto      0 0
    
    proc       /proc        proc      defaults          0 0
    shm        /dev/shm    tmpfs    nodev,sosuid,noexec 0 0

  9. #8
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    Try using "defaults" instead of "default". That may or may not fix it, but it is worth a shot.

    Also, on your shm options, it should be "nosuid" instead of "sosuid".

    Linux User #376741
    Code is Poetry

  10. #9
    Just Joined!
    Join Date
    Feb 2007
    Posts
    20
    great! that fixed it , thanks
    damn typos lol

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •