Find the answer to your Linux question:
Results 1 to 4 of 4
initially i cannot play any music as root if i run volume control in the sound&video of applications i see that some are muted if i unmute them i am ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2006
    Posts
    5

    problems with sound card


    initially i cannot play any music
    as root if i run volume control in the sound&video of applications
    i see that some are muted
    if i unmute them i am able to play music
    but for every time i boot into gentoo i have to do this
    but this only works as root
    when i try to run volume control as a user it shows the following message
    "No volume control GStreamer plugins and/or devices found"
    why am i unable to do this as user .. i am unable to listen to music as a user?
    I need to login as root and unmute in the volume control evrytime to listen to music
    also "su" is not working
    it keeps saying permission denied
    why is this so?

    should i install alsa and try alsaconf??
    if so how.. coz "emerge" does not work here keeps getting timed out
    also we have a lot of connection problems so how to use "emerge"
    /var/cache can u please help me out

  2. #2
    Just Joined!
    Join Date
    Jan 2005
    Location
    Idaho
    Posts
    35
    What sound card do you have?
    "lsmod |grep ^snd"
    Have you tried using alsamixer or aumix?

  3. #3
    Just Joined!
    Join Date
    Oct 2006
    Posts
    5
    this is what the command gives

    snd_hda_intel 11956 4
    snd_hda_codec 101120 1 snd_hda_intel
    snd_pcm 45156 3 snd_hda_intel,snd_hda_codec
    snd_timer 14212 2 snd_pcm
    snd 30564 10 snd_hda_intel,snd_hda_codec,snd_pcm,snd_timer
    snd_page_alloc 6024 2 snd_hda_intel,snd_pcm

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jan 2005
    Location
    Idaho
    Posts
    35
    Do this as root:
    lspci | grep -i audio

    btw-did you list yourself in the audio group of /etc/group?

    Some reading for you perhaps (if you haven't already):
    http://www.gentoo.org/doc/en/alsa-guide.xml
    http://gentoo-wiki.com/HOWTO_ALSA_Co...cludes_dmix%29


    Perhaps try:
    http://forums.gentoo.org/index.php

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •