Find the answer to your Linux question:
Results 1 to 8 of 8
Ok, I'm having crazy issues with my sound. I get no sound in KDE, and I have loaded another kernel from a user whose sound worked fine on the same ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2007
    Posts
    4

    Sound issues


    Ok, I'm having crazy issues with my sound. I get no sound in KDE, and I have loaded another kernel from a user whose sound worked fine on the same spec system, but it was no help. I have been through the ALSA guide, and through numerous google searches on the subject with no help found. I'm going to post as much relevant information as I can. I have attempted to run a make modules_install, and the soundcore module shows up fine, but when I attempt to perform a modprobe on the drivers I was told to use, the error I receive is below. Other than this, there are no error messages given, the sound just does not work. If something else is needed, please let me know and possibly let me know the commands needed to get it as I do not consider myself a linux "power user" by any means.

    Thanks for your help

    Code:
    # modprobe snd-hda-intel
    WARNING: Error inserting snd_page_alloc (/lib/modules/2.6.19-gentoo-r5/kernel/sound/core/snd-page-alloc.ko): Invalid module format
    WARNING: Error inserting soundcore (/lib/modules/2.6.19-gentoo-r5/kernel/sound/soundcore.ko): Invalid module format
    WARNING: Error inserting snd (/lib/modules/2.6.19-gentoo-r5/kernel/sound/core/snd.ko): Invalid module format
    WARNING: Error inserting snd_timer (/lib/modules/2.6.19-gentoo-r5/kernel/sound/core/snd-timer.ko): Invalid module format
    WARNING: Error inserting snd_pcm (/lib/modules/2.6.19-gentoo-r5/kernel/sound/core/snd-pcm.ko): Invalid module format
    WARNING: Error inserting snd_hda_codec (/lib/modules/2.6.19-gentoo-r5/kernel/sound/pci/hda/snd-hda-codec.ko): Invalid module format
    Code:
     # lspci | grep -i audio
    00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)

  2. #2
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    what happens when you run alsaconf (you need to install alsa-utils)
    Brilliant Mediocrity - Making Failure Look Good

  3. #3
    Just Joined!
    Join Date
    Mar 2007
    Posts
    4
    I ran alsaconf, and here is the output when it runs the scripts after it asks you all the questions:

    Code:
    Running modules-update...
     * Updating /etc/modules.conf ...                                         [ ok ]
     * Updating /etc/modprobe.conf ...                                        [ ok ]
     * Updating modules.dep ...                                               [ ok ]
    Loading driver...
     * Loading ALSA modules ...
     *   Loading: snd-card-0 ...
    WARNING: Error inserting snd_page_alloc (/lib/modules/2.6.19-gentoo-r5/kernel/sound/core/snd-page-alloc.ko): Invalid module format
    WARNING: Error inserting soundcore (/lib/modules/2.6.19-gentoo-r5/kernel/sound/soundcore.ko): Invalid module format
    WARNING: Error inserting snd (/lib/modules/2.6.19-gentoo-r5/kernel/sound/core/snd.ko): Invalid module format
    WARNING: Error inserting snd_timer (/lib/modules/2.6.19-gentoo-r5/kernel/sound/core/snd-timer.ko): Invalid module format
    WARNING: Error inserting snd_pcm (/lib/modules/2.6.19-gentoo-r5/kernel/sound/core/snd-pcm.ko): Invalid module format
    WARNING: Error inserting snd_hda_codec (/lib/modules/2.6.19-gentoo-r5/kernel/sound/pci/hda/snd-hda-codec.ko): Invalid module format                       [ ok ]
     *   Loading: snd-pcm-oss ...
    WARNING: Error inserting soundcore (/lib/modules/2.6.19-gentoo-r5/kernel/sound/soundcore.ko): Invalid module format
    WARNING: Error inserting snd (/lib/modules/2.6.19-gentoo-r5/kernel/sound/core/snd.ko): Invalid module format
    WARNING: Error inserting snd_page_alloc (/lib/modules/2.6.19-gentoo-r5/kernel/sound/core/snd-page-alloc.ko): Invalid module format
    WARNING: Error inserting snd_timer (/lib/modules/2.6.19-gentoo-r5/kernel/sound/core/snd-timer.ko): Invalid module format
    WARNING: Error inserting snd_pcm (/lib/modules/2.6.19-gentoo-r5/kernel/sound/core/snd-pcm.ko): Invalid module format                                      [ ok ]
     *   Loading: snd-seq ...
    WARNING: Error inserting soundcore (/lib/modules/2.6.19-gentoo-r5/kernel/sound/soundcore.ko): Invalid module format
    WARNING: Error inserting snd (/lib/modules/2.6.19-gentoo-r5/kernel/sound/core/snd.ko): Invalid module format
    WARNING: Error inserting snd_timer (/lib/modules/2.6.19-gentoo-r5/kernel/sound/core/snd-timer.ko): Invalid module format                                  [ ok ]
     * Restoring Mixer Levels ...                                             [ ok ]
    Setting default volumes...
    
    ===============================================================================
    
     Now ALSA is ready to use.
     For adjustment of volumes, use your favorite mixer.
    
     Have a lot of fun!
    I also started X after this ran, and sound still does not work

  4. #4
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    make sure the volume is not muted (it is like that often by default)
    Brilliant Mediocrity - Making Failure Look Good

  5. #5
    Just Joined!
    Join Date
    Mar 2007
    Posts
    4
    I checked alsamixer, and the volumes are not muted. They are turned all the way up for all of the channels

  6. #6
    Just Joined!
    Join Date
    Mar 2007
    Posts
    4
    ok, here's an update. I have gotten the sound to work...kind of. All sounds made by applications now seem to work. The only thing that is not working is actual KDE sounds. It seems that KDE cannot interface with ALSA to play the sounds. I have set KDE up to use play instead of the KDE sound system to play the system sounds, but this is not the best solution. I would like to have this fixed without reloading the entire thing, but that may be the only course of action left.

  7. #7
    Just Joined!
    Join Date
    May 2007
    Posts
    1

    how did you solve the sound problem?

    I'm experiencing the same problem.

  8. #8
    F50
    F50 is offline
    Just Joined!
    Join Date
    May 2009
    Posts
    1
    I remember having this problem too.

    If its just KDE sounds that are not working try opening the KDE control center -> Sound and Multimedia -> System Notifications. Click on "Player Settings" and select "use an external player". As your external player, put in anything that plays sound: kaffiene and kmplayer will work. Amarok will work too, its just more invasive.

    You should now get KDE sounds. You should also have an ugly program running all the time.

    A more elegant and permanent solution required placing an script into ~/.kde3.5/Autostart/

    If I remember correctly it was:
    Code:
    #!/bin/sh
    artsd -V $_VOLUME
    Where $_VOLUME is a value in dB that controls how loud you want your kde sound.

    Other options might be required such as "-a alsa" or "-D /dev/$_AUDIO_DEVICE_NAME". $_AUDIO_DEVICE_NAME should usually be "/dev/dsp"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •