Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
Hey folks, I am getting an error during the emerge kde-meta, I have tried to find the answer myself but no joy yet. I'm fairly certain that it's a QT ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864

    Emerging KDE error


    Hey folks, I am getting an error during the emerge kde-meta, I have tried to find the answer myself but no joy yet. I'm fairly certain that it's a QT library/header error but for the life of me, I cannot get it installed because I don't know the name of the package I suppose. Anyhoo, here is the error I get.
    error: Qt (>= Qt 3.3 and < 4.0) (headers and libraries) not found. Please check your installation.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  2. #2
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    I haven't used Gentoo in a while now, but you can get a list of packages with Qt in its name or description with this

    emerge --search | less

    You will need to be root or be in the 'portage' group
    Are you chrooting?
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  3. #3
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Quote Originally Posted by Juan Pablo View Post
    I haven't used Gentoo in a while now, but you can get a list of packages with Qt in its name or description with this

    emerge --search | less

    You will need to be root or be in the 'portage' group
    Are you chrooting?
    Yes I am still chrooting from FC6, I haven't gotten my wireless setup with Gentoo yet.
    I'll give the search a try, currently I'm waiting for QT-4 to compile, and of course that takes forever.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  4. #4
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    If you look at the error message, it says the version of qt required should be greater than or equal to 3.3 but less than version 4. I think what you need to do is emerge qt3.

  5. #5
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Yeah, that is what I thought too, so I did a search with emerge -s qt3 and only got one return, which was pyqt3 or something, definetly not what I was looking for. But I did find a different way which seems to be working so far, emerge -ud kde-meta, which is supposed to update everything and check the depends. We'll see!
    Will post back soon.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  6. #6
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    That failed too.
    I think it's already installed anyhow
    emerge -pv =x11-libs/qt-3*

    These are the packages that would be merged, in order:

    Calculating dependencies... done!
    [ebuild R ] x11-libs/qt-3.3.8-r2 USE="cups gif ipv6 opengl -debug -doc -examples -firebird -immqt -immqt-bc -mysql -nas -nis -odbc -postgres -sqlite -xinerama" 0 kB

    Total: 1 package (1 reinstall), Size of downloads: 0 kB
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  7. #7
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    Okie dokies!

    I got emerge to work, just by using
    Code:
    emerge kde
    Apparently emerge kde-meta is a bad thing, and I'll just install the extra KDE packages one by one.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  8. #8
    Linux Enthusiast gruven's Avatar
    Join Date
    Dec 2004
    Location
    Arkansas
    Posts
    541
    kde-meta isn't a bad thing, it just sounds to me like you didn't have the "qt3support" use flag on when you emerged qt4.

    Either way I am glad to see you got it working.

    Just FYI, when you used
    Code:
    emerge kde
    then you installed all of kde. You can't install the programs "one-by-one", as that is what the meta ebuilds are for. You have three choices for kde really. They are 1.)install the "kde" ebuild, which is monolithic, 2.)kde-meta, which will pull the individual programs in, and 3.)install the programs each individually without the -meta guidance.

    Linux User #376741
    Code is Poetry

  9. #9
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    I don't have it working yet, I'm still stuck on the KDE install. I do have a working Gentoo with no desktop (yet). Evidently I did something wrong, because I keep getting these blocked packages. Here is a sample. BTW, this list is just a sample and not the entire output.
    emerge -pv kde-meta

    These are the packages that would be merged, in order:

    Calculating dependencies... done!
    [ebuild N ] kde-base/libkdegames-3.5.5 USE="arts -debug -kdeenablefinal -kdehiddenvisibility -xinerama" 0 kB
    [ebuild N ] kde-base/libkonq-3.5.5 USE="arts -debug -kdeenablefinal -kdehiddenvisibility -xinerama" 0 kB
    [ebuild N ] kde-base/libkdenetwork-3.5.4 USE="arts -debug -kdeenablefinal -xinerama" 12,623 kB
    [ebuild N ] kde-base/libkmime-3.5.3 USE="arts -debug -kdeenablefinal -xinerama" 12,610 kB
    [ebuild N ] kde-base/libkdeedu-3.5.4 USE="arts -debug -kdeenablefinal -xinerama" 29,172 kB
    [ebuild N ] kde-base/kdemultimedia-arts-3.5.5 USE="-debug -kdeenablefinal -xinerama" 0 kB
    [ebuild N ] kde-base/libkcddb-3.5.5 USE="arts -debug -kdeenablefinal -xinerama" 0 kB
    [ebuild N ] kde-base/librss-3.5.0 USE="arts -debug -kdeenablefinal -kdehiddenvisibility -kdexdeltas -xinerama" 7,279 kB
    [ebuild N ] kde-base/kdebase-data-3.5.5 USE="-debug -kdeenablefinal -xinerama" 0 kB
    [ebuild N ] kde-base/kcminit-3.5.3 USE="arts -debug -kdeenablefinal -kdehiddenvisibility -xinerama" 23,081 kB
    [ebuild N ] kde-base/kdialog-3.5.5 USE="arts -debug -kdeenablefinal -kdehiddenvisibility -xinerama" 0 kB
    [ebuild N ] kde-base/ktnef-3.5.5 USE="arts -debug -kdeenablefinal -xinerama" 0 kB
    [ebuild N ] kde-base/libkholidays-3.5.5 USE="arts -debug -kdeenablefinal -xinerama" 0 kB
    And a bunch more, which looks good, until the end with all these packages being blocked
    [blocks B ] =kde-base/kappfinder-3.5* (is blocking kde-base/kdebase-3.5.5-r4)
    [blocks B ] =kde-base/kdemultimedia-arts-3.5* (is blocking kde-base/kdemultimedia-3.5.5)
    [blocks B ] =kde-base/kcheckpass-3.5* (is blocking kde-base/kdebase-3.5.5-r4)
    [blocks B ] =kde-base/kview-3.5* (is blocking kde-base/kdegraphics-3.5.5-r2)
    [blocks B ] =kde-base/kimagemapeditor-3.5* (is blocking kde-base/kdewebdev-3.5.5)
    [blocks B ] =kde-base/kwin-3.5* (is blocking kde-base/kdebase-3.5.5-r4)
    [blocks B ] =kde-base/juk-3.5* (is blocking kde-base/kdemultimedia-3.5.5)
    [blocks B ] =kde-base/kasteroids-3.5* (is blocking kde-base/kdegames-3.5.5)
    [blocks B ] =kde-base/quanta-3.5* (is blocking kde-base/kdewebdev-3.5.5)
    [blocks B ] =kde-base/kdebase-kioslaves-3.5* (is blocking kde-base/kdebase-3.5.5-r4)
    [blocks B ] =kde-base/kbattleship-3.5* (is blocking kde-base/kdegames-3.5.5)
    [blocks B ] =kde-base/ksmserver-3.5* (is blocking kde-base/kdebase-3.5.5-r4)
    [blocks B ] =kde-base/secpolicy-3.5* (is blocking kde-base/kdeadmin-3.5.5)
    [blocks B ] =kde-base/knotes-3.5* (is blocking kde-base/kdepim-3.5.5-r4)
    [blocks B ] =kde-base/kdepim-wizards-3.5* (is blocking kde-base/kdepim-3.5.5-r4)
    [blocks B ] =kde-base/ksysguard-3.5* (is blocking kde-base/kdebase-3.5.5-r4)
    [blocks B ] =kde-base/konsolekalendar-3.5* (is blocking kde-base/kdepim-3.5.5-r4)
    [blocks B ] =kde-base/kdeartwork-kwin-styles-3.5* (is blocking kde-base/kdeartwork-3.5.5)
    [blocks B ] =kde-base/kmix-3.5* (is blocking kde-base/kdemultimedia-3.5.5)
    [blocks B ] =kde-base/kdf-3.5* (is blocking kde-base/kdeutils-3.5.5)
    [blocks B ] =kde-base/kscd-3.5* (is blocking kde-base/kdemultimedia-3.5.5)
    I am still working on it, haven't given up yet as this took wayyyy too long to just give up and re-format/re-install.
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  10. #10
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    You have already emerged a bunch of kde-meta single ebuild, thus you won't be able to emerge the 'kde' monolithic ebuild because you would be emerging the same packages twice, for example you will need to unmerge kscd in order to emerge kdemultimedia
    kdemultimedia contains kscd
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •