Hello,
I moved my server stuff from my old RHEL4 server to a new Gentoo.

I am facing some problems with MySQL (and php?) though.

I backed up using cPanels feature. It gave me a .sql file.
I restored the backup using phpMyAdmin.

On the old server, connection collation was utf8_unicode_ci, and default charset was utf8 (all this according to phpmyadmin).

I configured the new server with the same settings. Here is also my config file:

streamkid.de/~alex/my.cnf
(no paste because its big)
The problem is that greek characters don't show up properly. You can have a look here about what i mean:
streamkid.de/~alex/blog/

Using a test.html, i verified that apache is correctly configures. Or at least the greeks chars on the file were properly displayed.

What have i misconfigured
Any help appreciated