Find the answer to your Linux question:
Results 1 to 5 of 5
I'm sorry to start another thread of this nature, but I wasn't certain someone would respond to another since the issue had already been resolved. I'd never configured my own ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2007
    Posts
    2

    Exclamation Where is eth0


    I'm sorry to start another thread of this nature, but I wasn't certain someone would respond to another since the issue had already been resolved. I'd never configured my own kernel until now and I'm trying to understand the boot process... so if you could please find time to respond:

    Does the module location vary from dist to dist because I've seen some documentation suggesting modules are found in /lib/modules/'kernel ver.'/ or do you always have to go into somewhere like /lib/modules/'kernel ver.'/kernel/drivers/?
    Are the same drivers found in lib, lib32, and lib64?

    I'm not getting eth0 when I use ifconfig, and I don't think the driver is loaded. I didn't change much with initial kernel configuration, so I think my Marvell Technology 88E8038 is compiled as the loadable module 'sky2'. However, if I try loading this manually using /etc/modules.autoload.d/modules or insmod it says there is a segmentation fault. I know the driver works though because it works properly for the minimal install cd.

    Also could someone explain the significance of net.eth0, because it's already there, but it doesn't initialize (I don't even think the driver is loaded though). Finally I emerged 'dchpcd' but when I run net.eth0 start it says that dchpcd ver. 2.xxx or greater is needed, but I know I have version 3.xxx installed at least. This needs to be an auto-loaded module? Do kernel compiled modules list with 'lsmod' because I don't get anything listed when I run the command.

    It's pretty frustrating because I can't check solutions for anything online when I don't have my network up and I have to keep rebooting.

  2. #2
    Just Joined!
    Join Date
    Aug 2007
    Posts
    3
    Hey there,

    Usually the kernel modules are located in /lib/modules/kernel_version/... but if you really wanted to move them somewhere else you could do this through the Makefile(MODLIB variable). Most distros that I'm aware of use this default path, at least the ones I used(Red Hat, Ferdora, Gentoo, Ubuntu,etc..) As for your second question, the driver you are using might have not been compiled properly. You could try emerging the newest kernel and use the the kernel config file from the live cd(/etc/kernelconfig/...) to recompile the kernel. Once you compile the kernel, you should add the module name to /etc/modules.autoload.d/kernel-2.6 so that when you start the machine the module gets loded. Also you could try compiling the module into the kenel. As for the 3 question, the net.xxx is the default configuration file that sets up your network interfaces. As far the dchpcd problem, I have no idea whats up with that. lsmod and insmod are utilities that only work with dynamic modules. insmod is used to load a module into the kernel and lsmod lists the currently loaded modules in the kernel.
    So if you staticaly compiled a module you dont need any of these utilities because the module is in the kernel and already loaded. Hope that answers some of your questions.

  3. #3
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    It's pretty frustrating because I can't check solutions for anything online when I don't have my network up and I have to keep rebooting.
    Get yourself a copy of Knoppix, (it has support for a lot of cards) and chroot to Gentoo, this way you will have net access to help you along.
    KNOPPIX Linux Live CD
    Gentoo Linux Documentation -- The Gentoo Linux alternative installation method HOWTO
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  4. #4
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    what does

    # modprobe sky2


    do?
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  5. #5
    Just Joined!
    Join Date
    Aug 2007
    Posts
    3

    Check

    Check to see if eth0 is located in /etc/init.d/net.eth0
    If not, you have to rebuild your module.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •