Find the answer to your Linux question:
Results 1 to 3 of 3
After I reboot, grub appears OK. when I select gentoo, and it starts all the checs, it gets stuck on >>Determining root device. It says that /dev/sda2 isn't a valid ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! eclaria's Avatar
    Join Date
    Jun 2007
    Location
    Buenos Aires, Argentina
    Posts
    8

    Problem after rebooting


    After I reboot, grub appears OK. when I select gentoo, and it starts all the checs, it gets stuck on >>Determining root device. It says that /dev/sda2 isn't a valid root device, and then asks for a valid one. As I'm new to Linux, I assumed that my root device is where I have the / (/dev/sdb3) but when I put that, it keeps saying the same, so I try with every partition on my disks, but no one seems to work. I checked fstab to look if it was wrong, but all the config was OK. I don't have a clue of what's going on... If someone could give some info about how to solve this, I would appreciate it very much.

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    post the contents of /etc/fstab and output of fdisk -l command.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined! eclaria's Avatar
    Join Date
    Jun 2007
    Location
    Buenos Aires, Argentina
    Posts
    8
    I've found that's not the problem. It's about the option real_root passed to the kernel. It seems that it's not recognizing my SATA drives, as they don't appear in ls /dev. Is there any way of installing the modules without recompiling the kernel? Where do I get the drivers? because the sata_nv that I need didn't appear in the available modules... Thanks for any help!

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •