Hello, Im having problems re-emerging apr

here the log

Code:
configure: creating ./config.status
config.status: creating Makefile
config.status: creating include/apr.h
config.status: creating build/apr_rules.mk
config.status: creating build/pkg/pkginfo
config.status: creating apr-1-config
config.status: WARNING:  apr-config.in seems to ignore the --datarootdir setting
config.status: creating apr.pc
config.status: creating test/Makefile
config.status: creating test/internal/Makefile
config.status: creating include/arch/unix/apr_private.h
config.status: executing default commands
make[1]: Entering directory `/var/tmp/portage/dev-libs/apr-1.2.8/work/apr-1.2.8'

gawk -f /var/tmp/portage/dev-libs/apr-1.2.8/work/apr-1.2.8/build/make_var_export.awk /var/tmp/portage/dev-libs/apr-1.2.$
gawk -f /var/tmp/portage/dev-libs/apr-1.2.8/work/apr-1.2.8/build/make_exports.awk /var/tmp/portage/dev-libs/apr-1.2.8/w$
/bin/sh /usr/bin/libtool --silent --mode=compile i686-pc-linux-gnu-gcc -pthread  -Os -march=i686 -pipe -DHAVE_CONFIG_H $
/bin/sh /usr/bin/libtool --silent --mode=compile i686-pc-linux-gnu-gcc -pthread  -Os -march=i686 -pipe -DHAVE_CONFIG_H $
libtool: compile: unable to infer tagged configuration
libtool: compile: specify a tag with `--tag'
make[1]: *** [passwd/apr_getpass.lo] Error 1
make[1]: *** Waiting for unfinished jobs....
libtool: compile: unable to infer tagged configuration
libtool: compile: specify a tag with `--tag'
make[1]: *** [strings/apr_cpystrn.lo] Error 1
make[1]: Leaving directory `/var/tmp/portage/dev-libs/apr-1.2.8/work/apr-1.2.8'
make: *** [all-recursive] Error 1

!!! ERROR: dev-libs/apr-1.2.8 failed.
Call stack:
  ebuild.sh, line 1615:   Called dyn_compile
  ebuild.sh, line 972:   Called qa_call 'src_compile'
  ebuild.sh, line 44:   Called src_compile
  apr-1.2.8.ebuild, line 66:   Called die

!!! Make failed
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/dev-libs/apr-1.2.8/temp/build.log'.