Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
Ok so i am working on my second install of Gentoo. I did a test run on an older comp to make sure i could do it before moving to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2004
    Posts
    48

    nvidia-kernel


    Ok so i am working on my second install of Gentoo. I did a test run on an older comp to make sure i could do it before moving to my primary comp because i didnt want to lose time figureing everything out. The test run went well. Only problems were with configuring X but i got it all werked out eventually. I am fairly new to linux i have been using it steadily for about 3 months now i ahve used mandrake and fedora cores 1 and 2. I moved to gentoo partly because of the challenge but mostly because of the flexibility.

    However today i compiled the kernel and emerged my nforce and nvidia mods. However nforce-audio and nforce-net failed to emerge. I dont remember the exact error messages, but i am more concerned with my vidoe from nvidia-kernel. It emerged fine into /lib/modules/2.6.7 ...whatever the defualt was. Now when i tried modprobe nvidia, it gave me an error that it was an incorrect format of a module or somethign like that. It definintely found the mod as the error message pointed to the directory it was in. I even tried to make a link from the nvidia.ko to an nvidia.o figuring maybe it wanted a ".o" instead of a ".ko"

    Luckily i compiled the nv driver into the kernel incase. so X works for now. Or maybe not. Could it be that the nv driver is blocking my nvidia from being loaded. If so i tried to rmmod nv but it said it couldnt find it. I compiled it directly to the kernel. DO i need to recompile, is there an easy fix, or whatever. SOrry about the book i just wrote but i figured details are better.

    PS nvidia was in the autoload.d but i saw it fail to load during startup...dont know if that helps.

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Details are good.

    Did you change the symlink /usr/src/linux? You must rm this and ls -s /usr/src/linux-2.6.7-gentoo (or whatever your new kernel is) /usr/src/linux. Then re-emerge your nvidia stuff.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Just Joined!
    Join Date
    Jan 2004
    Posts
    48
    Well unfortunately that didnt do it. I got kde working this afternoon with my existing driver but i still get the same error message.

    bash-2.05b# modprobe nvidia
    FATAL: Error inserting nvidia (/lib/modules/2.6.7-gentoo/video/nvidia.ko): Invalid module format
    do i first need to remove my current driver, is it blocking my load of the nvidia one???

    i am stuck...but hey at least i got gentoo working for teh most part lol

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Stockholm, Sweden
    Posts
    1,296
    I dont recall having to modprobe the nvidia kernel. I jsut did emerge nvidia-kernel and emerge nvidia-glx and it worked:) that was a while ago though and i have an ATI card now

  6. #5
    Just Joined!
    Join Date
    Jan 2004
    Posts
    48
    Well reguardless of the modprobe, the module fails to load at start. It is in my modules.autoload/kernenl-2.6. SO when i have my XF86 config set to nvidia instead of nv it just faisl to startX because it cant find the mod. During boot i see

    loading nvidia *
    failed to load nvidia !!

    no reason just failed How can i fix this

  7. #6
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Post the output of:

    Code:
    ls -al /usr/src/
    uname -r
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  8. #7
    Just Joined!
    Join Date
    Jan 2004
    Posts
    48
    bash-2.05b$ ls -al /usr/src
    total 12
    drwxr-xr-x 3 root root 4096 Jun 22 16:39 .
    drwxr-xr-x 16 root root 4096 Jun 23 06:04 ..
    -rw-r--r-- 1 root root 0 Jun 21 00:09 .keep
    lrwxr-xr-x 1 root root 18 Jun 22 16:39 linux -> linux-2.6.7-gentoo
    drwxr-xr-x 19 root root 4096 Jun 23 05:46 linux-2.6.7-gentoo
    bash-2.05b$ uname -r
    2.6.7-gentoo

  9. #8
    Just Joined!
    Join Date
    Jun 2004
    Posts
    2

    Nvidia-Kernel

    I've had the same problem after upgrading my gentoo-kernel to 2.6.7. It seems to be an bug in the nvidia-kernel-modul. I upgraded it (and nvidia-glx) to version 1.0.5336-r2. Now it works! Even it's marked testing in the portage I had no problem with it by now.

  10. #9
    Just Joined!
    Join Date
    Jan 2004
    Posts
    48
    Thanks alot, however ther eis still a problem. The new driver compiles and i am able to modprobe it, and it does load automatically at start fine. But when i try to startx, or have nvidia as the module in the Device section of XF86Config, i jsut get a blank screen. No error, X just doesnt start. I cant check the logs because X doesnt start and they only record errors once it starts i guess. I repeat i get no error, just a blank screen. Here are the steps i used, right from gentoo.org's guide jsut so u cna see what i did

    emerge nvidia-glx (ACCEPT KEYWORDS ~86 etc for the new verision) (1.0.5336-r2)
    emerge nvidia-kernel (1.0.5336-r4)
    opengl-update nvidia (it said some stuff like switching to OpenGL iinterface Nvidia)
    Added nvidia to autoload.d
    ran 'startx'

    then the screen goes blank and never comes back. The same ting happens if i reboot and it tries to startx. Does anyone ahve any ideas, or knwo a better place to look for such a problem if there is one. Thanks

  11. #10
    Just Joined!
    Join Date
    Jun 2004
    Posts
    2
    Seems to me that you have some problem in your XF86Config. Can you post the sections regarding to the nvidia-driver?
    Another reason for your problem maybe a setting in your kernel-config. I googled some and found the following thread which hopefully can help you:
    http://forums.gentoo.org/viewtopic.php?t=152864

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •