Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
I use GIMP 2.0 on SuSE 9.1 and KDE. I use Canone i950 with driver PIXUS950 from Canon. I works perfectly in yast priter test (in photo mode, also printouts ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2004
    Posts
    50

    Printing from GIMP on Canon i950 without results


    I use GIMP 2.0 on SuSE 9.1 and KDE.
    I use Canone i950 with driver PIXUS950 from Canon. I works perfectly in yast priter test (in photo mode, also printouts from Digicam.
    But when I try to print form GIMP there nothing coming out of the printer. The job os processing in print queue.
    I also noticed that in print command in GIMP I can not select media type (photopaper)
    GiMP uses following command: lp -s -dcanon_i950 -oraw
    I tied to set upprinter on printing form in GIMP, but there is no my printer, it is on postscrip by default.

    Perhaps somene has and idea what I can do.
    Thanks in advance.

  2. #2
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Farnborough, UK
    Posts
    1,305
    From the print menu select New Printer and give it a name. Then select setup printer. Select PS level 2, put in the command you use for printing and point it to the ppd file.

    For me I use lpr-cups to print.
    Lansbury's Lido

    thekiadriver on #linuxforums - fleetingly

  3. #3
    Just Joined!
    Join Date
    Sep 2004
    Posts
    50

    Cups

    I introduce the command with cups as you pointed out with the right ppm.
    Now I can configure wthe right printer.
    Nevertheless printer is still deaf. The job is wainting in the queue.
    Any hints?
    Perheps It is question of priviligies?

  4. #4
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    I have an i850. Where did you find the printer driver?

    Thanks,
    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  5. #5
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Farnborough, UK
    Posts
    1,305
    For the print command just use lpr-cups. Don't add anything else to the line.
    Lansbury's Lido

    thekiadriver on #linuxforums - fleetingly

  6. #6
    Just Joined!
    Join Date
    Sep 2004
    Posts
    50

    i850

    Jeremy,

    Look there:
    ftp://download.canon.jp/pub/driver/bj/linux/

    It is in japanese but you should cope with.
    Their name for i850 is pixus850. But that is exactly the same.

    good luck

  7. #7
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    Thanks, I'll give it a try tonight!

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  8. #8
    Just Joined!
    Join Date
    Sep 2004
    Posts
    50
    Jeremy,
    What are the results?

    I still can not print. When I try to print test page it says that there is client error.

    Do anyone knows good instruction - step by step - to configure cups?

  9. #9
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    Sorry, I forgot about this. I'll get back to you soon. Thanks for the reminder.

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

  10. #10
    Linux Guru
    Join Date
    Mar 2003
    Location
    Wisconsin
    Posts
    1,907
    Sorry for the long delay. Here are the results. I installed both files using rpm on MDK 10.1. When I try to install the driver using CUPS, it isn't there. When I try to select .ppd file, it tells me it in an invalid format. What am I doing wrong?

    Jeremy
    Registered Linux user #346571
    "All The Dude ever wanted was his rug back" - The Dude

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •