Find the answer to your Linux question:
Results 1 to 2 of 2
Hi folks, I have an annoying problem related to Inkscape and do not have it very clear how to solve it. So perhaps you can help me: I work in ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! hernandeangelis's Avatar
    Join Date
    Mar 2005
    Location
    Planet Earth
    Posts
    79

    Inkscape can open ps and sk files but only as root


    Hi folks,

    I have an annoying problem related to Inkscape and do not have it very clear how to solve it. So perhaps you can help me:

    I work in SuSE 9.3 and normally install everything with YaST. I generate maps with GMT in postcript format (ps). Then I transform them into skencil (sk) files with pstoedit to import in Inkscape (0.41), where I make them nicer.

    The problem is that yesterday I tried to install a pstoedit plugin for export to svg but I didn't work. So I took away it. Then I could not open sk files any more, there was a message saying that it was an error an could not open it (just that, no more information in the message). I thoought I could have messed something and proceed to reinstall plotutils, pstedit, skencil and Inskcape. Now everything works, I can even open ps files in Inkscape ... but only as root.

    I will appreciate any tip you can give in this subject.

  2. #2
    Just Joined! hernandeangelis's Avatar
    Join Date
    Mar 2005
    Location
    Planet Earth
    Posts
    79
    Update:

    Trying from the command line:

    > inkscape g.sk
    /opt/gnome/share/inkscape/extensions/sk2svg.sh: line 9: /tmp/tmp.kHVHU21535/sk2svg21533.svg: No existe el fichero o el directorio (i.e. file doesn't exists)
    Extension::Script: Unknown error for pclose
    : Conseguido
    /tmp/ink_ext_IJa40G:1: parser error : Document is empty

    ^
    /tmp/ink_ext_IJa40G:1: parser error : Start tag expected, '<' not found

    ^

    ** (inkscape:21532): CRITICAL **: void sp_document_set_uri(SPDocument*, const gchar*): assertion `document != NULL' failed


    Any ideas?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •