The problem I have with the newest (2.4) lightcraft is it requires sse2 support, which my athlonxp2200 does not have.