Find the answer to your Linux question:
Results 1 to 4 of 4
Gi guys, Before I go into my problem I ll give you guys some background info. I recently bought a Asus F3Sv and installed Ubuntu on it. I also upgraded ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2007
    Posts
    2

    Disabling a Device in Linux


    Gi guys,

    Before I go into my problem I ll give you guys some background info. I recently bought a Asus F3Sv and installed Ubuntu on it. I also upgraded the ram amount to 4Gb. And thats where my problem kicks in. If I run ubuntu with 2GB of ram, the nvidia card works fine, however if I start it with 4GB of ram, the nvidia card crashes the Xserver severly (not even giving a log). After some serious digging I found that people had the same problem on XP. After installing 4GB of ram, XP would not be able to use the nvidia driver and users where forced to use the VGA driver.

    Now, there has been a work around for the windows box which is disabling one of the PCI ports which arent used anyway. In windows, that is a piece of cake and proved to work.

    I love linux, but I have been digging for hours and couldnt find a straight-forward solution to disable a device in linux. One of the ideas I had was to use the -reserve argument while booting, but I was not able to figure out what to put into the reserve argument. I tried many possibilities and nothiing seemed to have had an effect.

    The other way I thought one could use is to use the pci_disable_device() function call and write a small program myself (and I doubt that would work).

    Has anyone any solution to this problem? Or do I need to push on Asus to release a bios which is going to give me an option to disable the pci ports?

    I really very appreciate any ideas as I dont like using windows and want to migrate to linux asap

  2. #2
    Just Joined!
    Join Date
    Aug 2007
    Posts
    33
    #use the commands
    scanpci
    or
    pcitweak

    #check out the man pages or help flag for more info.

  3. #3
    Linux Newbie
    Join Date
    Dec 2005
    Location
    Toronto
    Posts
    127
    Have you tried using the vga or framebuffer driver in linux and see if that works ? That could provide you a temporary work around until you could resolve the problem with nvidia drivers with 4GB RAM.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Aug 2007
    Posts
    2
    thanks for the answers . I tried setpci and pcitweak but its only used to change values, I would love to just disable from being probed and not assigned any resources at all. It seems difficult to do in linux...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •