Hi All!
I am having problems dumping raw text to a line printer. I just switched over my office computer ( dual boot ) to Ubuntu 7.04. I have several batch files in Windows that I rewrote for bash in Linux.
One of the problems I had was copying files to a printer. The DOS equivalent is:
copy file.txt lpt1

Well, I used cat file.txt >/dev/lp0

That worked great for 2 days! Then the printer jammed...After that I tried turning off the printer and resetting the paper. When I tried the command, I received an error of 'permission denied' when I used sudo. When I logged in as root, nothing happened.

So I reboot into windows in order to have the reports print overnight. After getting to the office, I log back into ubuntu. Now I am getting the error that 'the resource is busy' when I use sudo, and nothing with root.

Is it possible that when the printer jammed and all of the files were not 'dumped' to the printer, that the files are in limbo and trying to print, but something is telling linux that the port is bad? (I know it is not as I am using windows to print the reports daily.)

If so, how do I clear this up? If not, what else could be my problem?
This should be a pretty simple task, I just don't have the know how yet to make it easy.

Thanx on advance!
Ubuntu 7.04
Okidata ML 590