Find the answer to your Linux question:
Results 1 to 3 of 3
Edited: Oops...... I think this topic is nearly useless..... I just realized I could test my method probably with no risk... I'd just need to backup the files on udev ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Apr 2007
    Posts
    214

    Newbiesque idea to get my scanner to work


    Edited: Oops...... I think this topic is nearly useless..... I just realized I could test my method probably with no risk... I'd just need to backup the files on udev when running from the live distro, and if the installation doesn't work, I'd just restore the old ones from the live distro.... well, I'm going to try that, and if it works I'll post here, hopefully could be useful for someone in a similar situation... next time I'll think a bit further before posting...


    __________________________________________________ __

    I'd appreciate the review of people who understand more of linux than me...

    The situation currently is that the scanner does not work on debian... sane is installed; sane-find-scanner finds the scanner (both as super user and regular user [which is in the group "scanner" BTW]), but nothing else; as a SU, scanimage -L detects the scanner, but as a regular user, no scanner is found by the same command; gimp/xsane as a SU will have the option to use the apparently detected scanner, but will not actually work - the preview image will be totally black, and the scanner remains totally silent and moveless. As a regular user, there would not be the scanner to select from the list, neither the whole GUI for scanning images.

    I've tried many things, related with scanner itself and with permissions...

    With kurumin, in the other hand, which is knoppix-based live distro, it detects the scanner promptly, with no hassle, and it just works.

    So the basic idea would be to get files generated from knoppix and replace the debian ones with them...

    But.... the files I guess I'd need to replace would be the ones on the /etc/udev folder.... (since the ones on the sane.d already are the same)

    Would that be safe or could totally mess up the installation? I'm a bit afraid because one of my prior ideas was to purge udev and scanner-related things, then reinstall... but if I mark to purge (or just remove) udev on adept manager, it will also mark to remove kernels and many of other essential stuff, which makes me think that udev itself is very essential, thus my plan wouldn't work

    Then I thought to replace udev with hotplug, simply by installing the latter, which automatically marks to uninstall udev, but it also marks to uninstall the rest of the essential stuff

    But in the other hand..... since it's the same computer, with the same hardware.... and knoppix is closely related to debian.... perhaps it could be safe...


    Thanks in advance for some enlightenment on this question...

  2. #2
    Linux Newbie
    Join Date
    Apr 2007
    Posts
    214
    Didn't work. And besides that problem of permissions, there's another one related to new kernels with some "USB-suspend" thing, which hinders scanners from working all the time. Adittionally, I got to compile a kernel without it. I tried to do this, but I think it didn't work due to lack of space or something else...

  3. #3
    Linux Newbie
    Join Date
    Apr 2007
    Posts
    214
    I got it working now!

    What I've got to do was to compile another kernel without the usb-suspend thing, solely;

    The permission issue was ultimately solved by adding the fstab line:

    none /dev/bus/usb usbfs defaults,devmode=0666 0 0

    As a note for someone else that may have the same problem, it may need to be /proc/bus/usb instead of /dev/ on that line, depending on whether one has udev or hotplug, if I got it right.

    I'm so happy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •