Find the answer to your Linux question:
Results 1 to 2 of 2
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    My new video card! Yay?

    "Sweet!" I thought to myself as I opened the box and crammed it into it's special haven safe in my case, "This is going to help me so much!"

    I upgraded to a BFG GeForce 6200 OC from ... some crappier card. I play WoW and Nexuiz on Ubuntu Feisty and I wanted to up the frames a bit cause I was getting a mere 10 on WoW and a simple explosion in Nex would make me skip 20. I knew it was the video card cause its like 6-7 years old. I did make sure to check that the driver supports the card. It does. Should I compile the driver from the nvidia site or should I be using the one from the "Restricted Driver Manager"?

    I uninstalled the driver through the "Restricted Drivers Manager" and restarted (to make sure it took... windows habit) then shut it down to install it. I uninstalled it because I was unsure whether there was a specific config file for the old card used. Popped in the new card, fired it up. Had to do a dpkg-reconfigure xserver-xorg because Xserver decided not to show up after installing (had to use the recovery console because the login prompt would not either). Rebooted and it worked. Great!

    Installed the driver again through the "Restricted Drivers Manager." Everything is working fine.... kinda. It did help my gaming a lot though.... by 3 frames. So now I get 13 frames per second in WoW! "This doesn't seem very reasonable for a 60 dollar upgrade," I thought.

    Did some searching and found to try "nvidia-xconfig" which is supposed to change the configuration somehow to xorg.conf. Restarted X. No difference.

    Did a "lspci -v" and tried to find what my video card was described as:
    01:00.0 VGA compatible controller: nVidia Corporation NV44A [GeForce 6200] (rev a1) (prog-if 00 [VGA])
            Subsystem: Unknown device 19f1:0000
            Flags: bus master, 66MHz, medium devsel, latency 248, IRQ 5
            Memory at ce000000 (32-bit, non-prefetchable) [size=16M]
            Memory at c0000000 (32-bit, prefetchable) [size=128M]
            Memory at cd000000 (32-bit, non-prefetchable) [size=16M]
            [virtual] Expansion ROM at cfee0000 [disabled] [size=128K]
            Capabilities: [60] Power Management version 2
            Capabilities: [44] AGP version 3.0
    and "lshw":

                    description: VGA compatible controller
                    product: NV44A [GeForce 6200]
                    vendor: nVidia Corporation
                    physical id: 0
                    bus info: pci@01:00.0
                    version: a1
                    size: 128MB
                    width: 32 bits
                    clock: 66MHz
                    capabilities: vga bus_master cap_list
                    configuration: driver=nvidia latency=248 maxlatency=1 mingnt=5
                    resources: iomemory:ce000000-ceffffff iomemory:c0000000-c7ffffff iomemory:cd000000-cdffffff irq:5
    My card is a - BFG Tech BFGR62256OC GeForce 6200 256MB 64-bit DDR AGP 4X/8X Video Card - Retail . As you can see, the specs are not being used as much as they could be. I realize it may not be able to utilize the full 256mb but the clock speed is way off. I do not know if this is even a problem, I just want some advice if it is!

    I was hoping one of the very knowledgeable Ubuntu gods could give me a hand!

    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Thu Nov  9 17:55:20 PST 2006
    # /etc/X11/xorg.conf (xorg X Window System server configuration file)
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    # Edit this file with caution, and see the xorg.conf(5) manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    Section "ServerLayout"
        Identifier     "Default Layout"
        Screen         "Default Screen" 0 0
        InputDevice    "Generic Keyboard"
        InputDevice    "Configured Mouse"
        InputDevice    "stylus" "SendCoreEvents"
        InputDevice    "cursor" "SendCoreEvents"
        InputDevice    "eraser" "SendCoreEvents"
    Section "Files"
    	# path to defoma fonts
        FontPath        "/usr/share/fonts/X11/misc"
        FontPath        "/usr/share/fonts/X11/cyrillic"
        FontPath        "/usr/share/fonts/X11/100dpi/:unscaled"
        FontPath        "/usr/share/fonts/X11/75dpi/:unscaled"
        FontPath        "/usr/share/fonts/X11/Type1"
        FontPath        "/usr/share/fonts/X11/100dpi"
        FontPath        "/usr/share/fonts/X11/75dpi"
        FontPath        "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    Section "Module"
        Load           "bitmap"
        Load           "ddc"
        Load           "extmod"
        Load           "freetype"
        Load           "glx"
        Load           "int10"
        Load           "vbe"
    Section "InputDevice"
        Identifier     "Generic Keyboard"
        Driver         "kbd"
        Option         "CoreKeyboard"
        Option         "XkbRules" "xorg"
        Option         "XkbModel" "pc105"
        Option         "XkbLayout" "us"
    Section "InputDevice"
        Identifier     "Configured Mouse"
        Driver         "mouse"
        Option         "CorePointer"
        Option         "Device" "/dev/input/mice"
        Option         "Protocol" "ImPS/2"
        Option         "ZAxisMapping" "4 5"
        Option         "Emulate3Buttons" "true"
    Section "InputDevice"
        Identifier     "stylus"
        Driver         "wacom"
        Option         "Device" "/dev/input/wacom"
        Option         "Type" "stylus"
        Option         "ForceDevice" "ISDV4"# Tablet PC ONLY
    Section "InputDevice"
        Identifier     "eraser"
        Driver         "wacom"
        Option         "Device" "/dev/input/wacom"
        Option         "Type" "eraser"
        Option         "ForceDevice" "ISDV4"# Tablet PC ONLY
    Section "InputDevice"
        Identifier     "cursor"
        Driver         "wacom"
        Option         "Device" "/dev/input/wacom"
        Option         "Type" "cursor"
        Option         "ForceDevice" "ISDV4"# Tablet PC ONLY
    Section "Monitor"
        Identifier     "acer 19WS"
        HorizSync       28.0 - 72.0
        VertRefresh     43.0 - 60.0
        Option         "DPMS"
    Section "Device"
        Identifier     "BFG GeForce"
        Driver         "nvidia"
    Section "Screen"
        Identifier     "Default Screen"
        Device         "BFG GeForce"
        Monitor        "acer 19WS"
        DefaultDepth    24
        Option         "UseFBDev" "true"
        Option         "AddARGBVisuals" "True"
        Option         "AddARGBGLXVisuals" "True"
        Option         "NoLogo" "True"
        SubSection     "Display"
            Depth       1
            Modes      "1440x900" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
        SubSection     "Display"
            Depth       4
            Modes      "1440x900" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
        SubSection     "Display"
            Depth       8
            Modes      "1440x900" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
        SubSection     "Display"
            Depth       15
            Modes      "1440x900" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
        SubSection     "Display"
            Depth       16
            Modes      "1440x900" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
        SubSection     "Display"
            Depth       24
            Modes      "1440x900" "1280x854" "1280x800" "1280x768" "1200x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
    PS. I posted this in the ubuntuforum site and was unable to get any help. I hope somebody here can aid me!

  2. #2
    Just Joined!
    Join Date
    Jan 2007
    okay, everything looks right to me except for the 256mb. The clock speed shown is the bus speed( the transfer speed of the agp bus (66Mhz)). I cannot see why it would not show the full amount. The 6200 is a very weak card though so I would not expect too much performance out of it. If you can return it, Newegg has a 6800 for about $75 that would put you much better off than the 6200.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts