Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 14 of 14
I think your rootnoverify line should read: Code: rootnoverify (hd1,0) not what you currently have: Code: rootnoverify (hd1) And also you can add 'makeactive' under the chainloader line.. everyone else ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Stockholm, Sweden
    Posts
    1,296

    I think your rootnoverify line should read:

    Code:
    rootnoverify (hd1,0)
    not what you currently have:

    Code:
    rootnoverify (hd1)
    And also you can add 'makeactive' under the chainloader line.. everyone else seems to have that when booting windows.
    The filesystem in use by windows makes no difference whatsoever to the grub boot sequence.

  2. #12
    Linux Newbie
    Join Date
    Apr 2004
    Posts
    173
    I tried changing the 'rootnoverify' and I added the 'makeactive' command, but neither fix the error:

    Code:
    root (hd1,0) 
      Filesystem type unknown, partition type 0x7
    I was searching through the possible commands and I saw there was a 'parttype' What exactly does that do, and could it be a possible fix?

  3. #13
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    The original rootnoverify command was obviously wrong. Anyhow, from what I know, Windows refuses to boot if it's not installed on the first hard drive. Fortunately, there's a workaround for that with GRUB. Try these commands instead:
    Code:
    title Windows
        rootnoverify (hd1,0)
        map (hd0) (hd1)
        map (hd1) (hd0)
        chainloader +1

  4. #14
    Linux Newbie
    Join Date
    Apr 2004
    Posts
    173
    Excellent! That fixed it. I was tired of swapping jumpers on the drive to switch between OS's. Thank you, and everyone else, who helped me with this. This has got to be one of the most helpful Linux forums I've yet to find, and I'll keep coming back. Thanks again to everyone!

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •