Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
On my primary HD, I have RedHat 9.1 installed. GRUB automatically starts when my system starts and asks me which OS to boot to. As of now, there is just ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Apr 2004
    Posts
    173

    Configuring GRUB for Windows


    On my primary HD, I have RedHat 9.1 installed. GRUB automatically starts when my system starts and asks me which OS to boot to. As of now, there is just my Linux OS. On my 2nd HD I have Windows 2000. Within Linux, how can I configure it to list Windows as a boot option?

    Also, when I am in Windows (if I set the Windows HD as master and Linux as slave, I will boot directly into Windows, but I am not able to browse into the Linux HD. Is this a security feature or a problem on my side?

    BTW, I did use the search feature before posting, but what I found di not necessarily help me 100%.

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    You need to add the following to your grub.conf:

    Code:
    title=Windows
    root (hd1,0)
    rootnoverify (hd1)
    chainloader +1
    That should enable you to choose between Windows and Linux at the grub prompt.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Linux Newbie
    Join Date
    Apr 2004
    Posts
    173
    I'll give that a shot. Thanks

  4. #4
    Just Joined!
    Join Date
    Oct 2003
    Location
    The Netherlands
    Posts
    89
    and as for browsing the linux partition in windows, there are some tools that allow you to do that, one of them is "explore2fs.exe"
    with this you can only read from the linux partition, not write to it.

    you can get it here.

  5. #5
    Linux Newbie
    Join Date
    Apr 2004
    Posts
    173
    Ok, actually I have one question before attempting this:

    The Linux HD will be my primary drive (HD1) and the Windows will be the slave or HD2. So, in grub.conf, would it be:

    Code:
    title=Windows 
    root (hd2,0) 
    rootnoverify (hd2) 
    chainloader +1

  6. #6
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Stockholm, Sweden
    Posts
    1,296
    No.. drive letters/numbers in grub start from the number 0 whereas under linux they start at A or 1 for a partition.

    /dev/hda1 in linux is (hd0,0) in grub.

    /dev/hdb3 in linux is (hd1,2) in grub

    :P confusing? - it sure is!!
    so it would actualy be as sarumont says :)

    It was a very good question though, and Important that you query these things if they concern you.

  7. #7
    Linux Newbie
    Join Date
    Apr 2004
    Posts
    173
    Awesome! Thanks for the quick response. Make sense...I jut gotta put it through my head that it goes that way.

  8. #8
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Just a small correction - it's supposed to be "title Windows", not "title=Windows".

  9. #9
    Linux Newbie
    Join Date
    Apr 2004
    Posts
    173
    I assumed it was 'title Windows' since it was like thatin the grub.conf file. Now, here lies the problem:

    I got it added to the menu. Here is the entire source:

    Code:
    # grub.conf generated by anaconda
    #
    # Note that you do not have to rerun grub after making changes to this file
    # NOTICE:  You have a /boot partition.  This means that
    #          all kernel and initrd paths are relative to /boot/, eg.
    #          root (hd0,0)
    #          kernel /vmlinuz-version ro root=/dev/hda2
    #          initrd /initrd-version.img
    #boot=/dev/hda
    default=2
    timeout=10
    splashimage=(hd0,0)/grub/splash.xpm.gz
    title Red Hat Linux (2.4.20-30.9)
    	root (hd0,0)
    	kernel /vmlinuz-2.4.20-30.9 ro root=LABEL=/ hdc=ide-scsi
    	initrd /initrd-2.4.20-30.9.img
    title Red Hat Linux (2.4.20-8)
    	root (hd0,0)
    	kernel /vmlinuz-2.4.20-8 ro root=LABEL=/ hdc=ide-scsi
    	initrd /initrd-2.4.20-8.img
    title Windows 2000 Professional
    	root (hd1,0)
    	rootnoverify (hd1)
    	chainloader +1
    When GRUB loads, the Windows option is automatically selected. If I select the Windows boot option, the screen will turn black like it is going to boot, and then it says that there is no operating system found. Any thoughts?

  10. #10
    Linux Newbie
    Join Date
    Apr 2004
    Posts
    173
    Here is the actual error:

    Code:
    Booting command-list
    
    root (hd1,0)
      Filesystem type unknown, partition type 0x7
    rootnoverify (hd1)
    chainloader +1
    
    Error loading operating system
    Hopefully that helps.

    BTW, the OS is Windows 2k Pro on NTFS if that means anything.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •