Find the answer to your Linux question:
Results 1 to 3 of 3
machine & distro: Dell 2.8 GHz Slackware 2.4.31 problem: cannot load rt2500.o module since dev ra0 doesn't exist background: - i downloaded RT2500-Linux-STA-1.4.6.6 device driver tarball from the RaLink website ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2007
    Posts
    2

    ralink rt2500 chipset -- linux won't create device ra0


    machine & distro:
    Dell 2.8 GHz
    Slackware 2.4.31

    problem:
    cannot load rt2500.o module since dev ra0 doesn't exist

    background:
    - i downloaded RT2500-Linux-STA-1.4.6.6 device driver tarball from the RaLink website

    - i untarred it, built and installed the rt2500.o driver, but a config script ifcfg-ra0 couldn't be created because the /etc/sysconfig/network-scripts directory didn't exist

    - i created the /etc/sysconfig/network-scripts directory and re-ran make install, which then ran smoothly (BTW the script contains the lines DEVICE=ra0, BOOTPROTO=dhcp, ONBOOT=yes)

    - the next step asked me to run modprobe rt2500 as root, which returned these errors

    /lib/modules/2.4.31/kernel/drivers/net/rt2500.o: init_module: No such device
    /lib/modules/2.4.31/kernel/drivers/net/rt2500.o: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters. You may find more information in syslog or the output from dmesg
    /lib/modules/2.4.31/kernel/drivers/net/rt2500.o: insmod /lib/modules/2.4.31/kernel/drivers/net/rt2500.o failed
    /lib/modules/2.4.31/kernel/drivers/net/rt2500.o: insmod rt2500 failed

    - likewise with the command ifconfig ra0 up

    what i've tried:
    - looked at lspci, it showed promise with this entry

    01:01.0 Network controller: RaLink: Unknown device 0301

    - looked in dmesg and syslog, but i don't see anything trying to establish this device as ra0

    - tried editing rc.inet1.conf to have it register a ra0 device, but on reboot nothing came of it

    what i'm wondering:

    - should that ifcfg-ra0 script be run sometime in the startup script lineup? or can the lines contained therein be inserted into an already existing script?


    Travis

  2. #2
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    I never tried the ralink rt2500 on the 2.4 kernel so I wouldn't be able to help you there. But I have used it with the 2.6 kernel and it compiled, modprobed, created ra0 and ran my pci wireless device satisfactorily. If you cannot find a solution, possibly consider updating your kernel to 2.6.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  3. #3
    Just Joined!
    Join Date
    Sep 2007
    Posts
    2

    Cool Ah yes

    I figured that's what someone would say. ;D

    One of the things that makes me curious, though, is what is the mechanism for creating a device? How does the kernel create a file 'ra0' in the /dev directory and link it to the pci device (as reported by lspci)?

    Anyways, thanks for the response, Dan.

    trav

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •