Find the answer to your Linux question:
Results 1 to 2 of 2
Hello, I have notebook with Synaptics touchpad and external mouse - Microsoft Natural Wireless Laser Mouse 6000. Problem is, that mouse is too fast. Movement speed I reduced with Code: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2007
    Posts
    1

    mouse scroll too fast


    Hello,
    I have notebook with Synaptics touchpad and external mouse - Microsoft Natural Wireless Laser Mouse 6000. Problem is, that mouse is too fast. Movement speed I reduced with
    Code:
    xset m 2/3 1
    , but I don't know how to reduce speed of scrolling.

    my xorg.conf:
    Code:
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "keyboard0" "CoreKeyboard"
        InputDevice    "mouse1" "CorePointer"
        InputDevice    "mouse0" "SendCoreEvents"
    EndSection
    ...
    Section "ServerFlags"
        Option         "AllowMouseOpenFail" "on"
    EndSection
    
    Section "InputDevice"
        Identifier     "keyboard0"
        Driver         "kbd"
        Option         "Protocol" "Standard"
        Option         "XkbLayout" "cz,us"
        Option         "XkbModel" "microsoft"
        Option         "XkbOptions" "grp:shift_toggle"
        Option         "XkbRules" "xfree86"
        Option         "XkbVariant" "nodeadkeys"
    EndSection
    
    Section "InputDevice"
        Identifier     "mouse0"
        Driver         "synaptics"
        Option         "Buttons" "5"
        Option         "Device" "/dev/input/mice"
        Option         "Emulate3Buttons" "on"
        Option         "HorizScrollDelta" "0"
        Option         "InputFashion" "Mouse"
        Option         "Name" "Synaptics;Touchpad"
        Option         "Protocol" "explorerps/2"
        Option         "SHMConfig" "on"
        Option         "Vendor" "Sysp"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
         Identifier "mouse1"
         Driver "evdev"
         Option "CorePointer"
         Option "Device" "/dev/input/event7"
         Option "Buttons" "9"
         Option "ZAxisMapping" "4 5"
         Option "DialRelativeAxisButtons" "6 7"
    EndSection
    ...
    Scrolling with touchpad works fine. I use two keys on keyboar for scrolling and it works fine too.

    openSUSE 10.2 kernel 2.6.22.5

    Could you help me?

  2. #2
    Just Joined!
    Join Date
    Oct 2007
    Posts
    1
    have the same problem (ms-wl-lm-5000). the only way i found to reduce speed -- use imwheel to replace scrolling events with keyboard up and down, but it's buggy due to buffering in keyboard events buffer.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •