Find the answer to your Linux question:
Results 1 to 5 of 5
i have just reinstalled rh 9.2 and on reboot everything went fine untill... hdb error: (somthing to do with dma) hdb: drive not ready for command {drive ready seekcomplete} etc ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Apr 2004
    Location
    Looe, Cornwall UK
    Posts
    152

    dma hell!!


    i have just reinstalled rh 9.2 and on reboot everything went fine untill...

    hdb error: (somthing to do with dma)
    hdb: drive not ready for command {drive ready seekcomplete}

    etc etc etc, it then did the same thing for hda as well.

    will try to get full error message if i can try to boot (i get a "grub>" command line at startup after i had to do a hard reboot)

    any ideas as to why this may be happening?

    oh by the way, if it will be faster to reinstall tell me cos i am going to need it to resurect a windoze computer from "spyware, hackers and virus hell" and if i used a windoze pc i would get infected as well (linux is immune to windoze viuses )
    Cry out for freedom! Cry out for Linux!

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Well, sorry to tell you, but that message often indicates hardware failures. You can try to turn off DMA on the hard drives, but that will make it much slower. I don't remember the kernel commandline option to do that, but once the system is up you can do it with "hdparm -d0 /dev/hda /dev/hdb".

  3. #3
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    It may be that you don't have the correct IDE chipset drivers in your kernel. I've had that problem when I forgot to compile them (DMA wouldn't turn on).
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  4. #4
    Just Joined!
    Join Date
    Jun 2004
    Location
    Leiria - Portugal
    Posts
    72

    Same kind problem

    Hi there,

    I'm with a dma problem too. I have a IBD Deskstar 40GB on a Mandrake 9.2 (kernel 2.4-22) and I notice that my /dev/hdc (the IBM's one) doesn't use dma. I've tried to set it on with hdparm -d1 /dev/hda but it doesn't do nothing to work.

    At the boot time there are few errors with hdc too, they talk about dma status == 0x620 or dma time out etc...

    In the harddrake the hdc isn't recognized as an IBM ide, wat sounds really weird to me...

    After some hours googling it seems that it is a problem with SMART feature of those ide's but how to solv it? It a driver/linux kernel solution or a firware one?

    Hope someone knows how...

    Thanks for your time.

  5. #5
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    SMART is implemented in the firmware. You can turn it on/off from the BIOS setup.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •