Find the answer to your Linux question:
Results 1 to 6 of 6
I have 40GB hard disk.I first installed Windows2003.The I installed Fedora2 leaving the windows2003 installed drive.Now I'm getting the both fedora and windows in the booting options but windows is ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2006
    Posts
    12

    Reg:Configuring Windows booting in grub.conf


    I have 40GB hard disk.I first installed Windows2003.The I installed Fedora2 leaving the windows2003 installed drive.Now I'm getting the both fedora and windows in the booting options but windows is not booting.When I give
    fdisk -l command in linux it shows the following:

    Device Boot start End Blocks Id System

    /dev/hda1 * 1 510 40965434+ 83 Linux
    /dev/hda2 511 1785 10241437+ 83 Linux
    /dev/hda3 2805 4864 16541280 f W95 Ext'd(LBA)
    /dev/hda5 4081 4864 62974484 b W95 FAT32
    /dev/hda6 2806 2870 522081 82 Linux Swap



    In grub.conf

    # grub.conf generated by anaconda
    #
    # Note that you do not have to rerun grub after making changes to this file
    # NOTICE: You do not have a /boot partition. This means that
    # all kernel and initrd paths are relative to /boot/, eg.
    # root (hd0,0)
    # kernel /vmlinuz-version ro root=/dev/hda1
    # initrd /initrd-version.img
    #boot=/dev/hda
    default=1
    timeout=10
    splashimage=(hd0,0)/boot/grub/splash.xpm.gz
    title Fedora Core (2.6.5-1.35
    root (hd0,0)
    kernel /vmlinuz-2.6.5-1.358 ro root=LABEL=/ rhgb quiet
    initrd /initrd-2.6.5-1.358.img
    title Windows
    rootnoverify (hd0,4)
    chainloader +1

    So please help in changing the grun.conf file.what are the changes in need to do?

    Thank you.

    Regards,
    Raghu

  2. #2
    Administrator MikeTbob's Avatar
    Join Date
    Apr 2006
    Location
    Texas
    Posts
    7,864
    I think if you change this: rootnoverify (hd0,4), to this: rootnoverify (hd0,3)
    I do not respond to private messages asking for Linux help, Please keep it on the forums only.
    All new users please read this.** Forum FAQS. ** Adopt an unanswered post.

    I'd rather be lost at the lake than found at home.

  3. #3
    Just Joined!
    Join Date
    Sep 2006
    Posts
    12
    Its not working.........

  4. $spacer_open
    $spacer_close
  5. #4
    Blackfooted Penguin daark.child's Avatar
    Join Date
    Apr 2006
    Location
    West Yorks
    Posts
    4,393
    Try (hd0,2) although I am not sure if it will work.

  6. #5
    Just Joined!
    Join Date
    Sep 2006
    Posts
    12
    I have tried all the combinations
    (hd0,x) x=0,1,2,3,4,5

    it gives error 16: Inserted disk not found

    even i tried the combinations (hdy,x) y=0,1,2,3,4,5

    please help in correcting the error.

  7. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    You have installed Linux after Windows. Why did you create partitions for Linux before Windows Partition? Your Windows OS has been messed up. Try to fix Windows first. Boot up from SuperGRUB CD and select 'Fix Windows Boot Loader' option from List.
    Does Windows OS boot up after fixing its Boot Loader?
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •