Find the answer to your Linux question:
Results 1 to 3 of 3
I have a 52x Cyberdrive ATAPI CDROM and although it shows up in the text when Slackware 10 starts up, it doesn't show up in devices in Konqueror. I then ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Location
    Wherever the beautiful women are.
    Posts
    99

    CDROM and external HD problem


    I have a 52x Cyberdrive ATAPI CDROM and although it shows up in the text when Slackware 10 starts up, it doesn't show up in devices in Konqueror.

    I then look in the fstab file and there isn't a line for it. Fortunately it recognises my Samsung CDRW so I'm OK for the time being. Is it just a driver problem or do I need to add something to the fstab to get it to work?

    Also, the internal HD that I converted into an external doesn't show up. There are only Mac and Windows drivers for it but I thought there might be some sort of generic driver I could use. I've enabled all the relevant USB support and hotplug options(or at least I think I have). Again, this doesn't need to be solved immediately. Both pieces of hardware work fine on XP Pro(the other half of my dual boot).

    I also came across the 'make symlinks dep' message, although I avoided this as I'm told it's not the best way to tackle these sort of issues.

  2. #2
    Linux Engineer
    Join Date
    May 2003
    Location
    Greece / Athens
    Posts
    1,169
    First of all make sure that the drive you specified is recognised in bios.if yes here is a helpful link how to edit your /etc/fstab file:https://www.cae.wisc.edu/fsg/linux/linux-fstab.html
    Linux For Ever!

  3. #3
    Just Joined!
    Join Date
    Jul 2004
    Location
    Wherever the beautiful women are.
    Posts
    99
    After looking at another site, I noticed something else was wrong, this time with my CD-RW. Although it detects it and shows up as a Samsung CDRW in the opening text, my fstab shows it as a cdrom. I didn't think this was a problem beforehand because both perform reading duties and I thought that's just the way that Slackware deals with them. Here's the line for my CDRW from the fstab:

    /dev/cdrom /mnt/cdrom iso9660 noauto,owner,user,ro 0 0

    I took the ro flag out because I thought that had something to do with the initial problems that I had. But now I've found it makes no difference so I put it back in. I believe this is what the line should look like:

    /dev/cd-rw/mnt/cd-rw iso9660 noauto,owner,user,ro 0 0

    and I should have a line for my CDROM which looks like what the CDRW line is at the moment, but because of what I mentioned in my previous post, there's no line for that at all.

    I've just about given up on my external hard disk, but if I can burn things on to CD, reboot into windows and copy them onto the disk from there (or leave them on CD) that would be fine aswell.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •