Find the answer to your Linux question:
Results 1 to 5 of 5
I have an internal ZIP-100 drive. I'm running SuSE 9.1 Professional. My boot.msg (log) file says that it found the IOMEGA ZIP 100 as hda: I'm a newbie but I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2004
    Location
    Colorado, USA
    Posts
    6

    Iomega ZIP 100 IDE help


    I have an internal ZIP-100 drive. I'm running SuSE 9.1 Professional. My boot.msg (log) file says that it found the IOMEGA ZIP 100 as hda:

    I'm a newbie but I have found the mount command and created a directory under /mnt/ for the zip drive.

    When I: mount /dev/hda /mnt/zip/ I get an error message saying I need to specify a filesystem type.

    When I: mount /dev/hda1 /mnt/zip I get an error message saying /dev/hda1 is not a valid block device.

    What gives? How can I make use of the ZIP drive?

    What I really want to do is have the zip drive function as it did in Window$ with an Icon on filesystem or desktop.

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    What filesystem is on the Zip Disk?

    Code:
    mount -t vfat /dev/hda /mnt/zip
    This will mount it if it is FAT16 or 32...change the vfat to ntfs if it is ntfs, though you won't be able to write ntfs.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Just Joined!
    Join Date
    Jul 2004
    Location
    Colorado, USA
    Posts
    6

    Need to Format ZIP

    I added an entry in /etc/fstab:
    /dev/hda /mnt/zip100.0 vfat noauto,user 0 0

    Now the device shows up, but any time I access the drive I get an error:
    Mount wrong FS type, bad option, bad superblock on /dev/hda

    Do I need to Format the media? I was hoping to beable to read/write MS Window$ files.

    Any ideas? Thanks

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Well...was it NTFS or FAT16/32? If it was NTFS, change the vfat to ntfs in your fstab. If it was FAT, then you probably don't have the kernel driver to read vfat installed or modprobed.

    You can try modprobe vfat (as root) to see if it's installed and not loaded. If not, then you'll have to recompile your kernel to include support for the fs (or as a module so you don't have to reboot).
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  6. #5
    Just Joined!
    Join Date
    Jul 2004
    Posts
    1
    >>I have an internal ZIP-100 drive. I'm running SuSE 9.1 Professional. My boot.msg (log) file says that it found the IOMEGA ZIP 100 as hda:

    I also have SuSE 9.1 the zip drive's directory information is located on partition #4

    it can be mounted manually as;
    mount -t vfat /dev/hda4 /media/zip
    assuming that you have created the directory zip under media

    on my computer the zip drive is hdb
    so I mount manually as ;
    mount -t vfat /dev/hdb4 /media/zip
    or in fstab;
    /dev/hdb4 /media/zip vfat noauto,users,nosuid 0 0
    will allow any user to mount the file system and unlike the "user" option any user may unmount it reguardless of ownership.
    hope this helps

    also if anybody knows how to format one of these things I want to know

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •