Find the answer to your Linux question:
Results 1 to 2 of 2
Hi everyone. My server is running under ASPLinux kernel 2.6.22.6. This is http server with 4 same SATA disks: Device Model: ST3500630NS Serial Number: 9QG2RBW8 Firmware Version: 3.AEG User Capacity: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2007
    Posts
    1

    Strange disk system problems


    Hi everyone. My server is running under ASPLinux kernel 2.6.22.6. This is http server with 4 same SATA disks:
    Device Model: ST3500630NS
    Serial Number: 9QG2RBW8
    Firmware Version: 3.AEG
    User Capacity: 500,107,862,016 bytes
    Device is: Not in smartctl database [for details use: -P showall]
    ATA Version is: 7
    ATA Standard is: Exact ATA specification draft version not indicated
    Local Time is: Fri Nov 9 14:13:52 2007 EET
    SMART support is: Available - device has SMART capability.
    SMART support is: Enabled
    Hardware:
    Intel(R) Core(TM)2 CPU 6320 @ 1.86GHz
    Intel® Entry Server Board S3000AH
    2GB RAM
    When users downloading files via http (apache Apache/2.2.6) server console so lugging! I even can't access to server via ssh

    System perfomance:

    iostat: rrqm/s wrqm/s r/s w/s rsec/s wsec/s rkB/s wkB/s avgrq-sz avgqu-sz await svctm %util
    sda 0,00 0,00 0,00 0,33 0,00 2,66 0,00 1,33 8,00 0,19 1236,00 568,00 18,87
    sdb 0,00 0,00 29,24 0,00 1783,39 0,00 891,69 0,00 61,00 0,19 6,64 6,05 17,67
    sdc 58,80 0,00 115,95 0,00 21597,34 0,00 10798,67 0,00 186,27 233,10 856,13 8,61 99,80
    sdd 25,58 0,00 121,93 0,00 19484,39 0,00 9742,19 0,00 159,80 1,13 9,31 4,11 50,10
    (Server has gigabit ethernet port for users downloads, average download speed 30-40 Mb\s)

    Top displaying very high wa time value:
    [root@nef sports]# top
    top - 14:18:27 up 2 days, 3:02, 3 users, load average: 80.78, 88.52, 94.84
    Tasks: 243 total, 4 running, 236 sleeping, 0 stopped, 3 zombie
    Cpu(s): 0.3% us, 2.3% sy, 0.0% ni, 0.0% id, 92.8% wa, 2.6% hi, 9.1% si
    Mem: 2068676k total, 2019796k used, 48880k free, 4832k buffers
    Swap: 1052216k total, 196k used, 1052020k free, 1914448k cached

    PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
    24565 igorek 15 0 3996 976 588 D 1.0 0.0 0:01.49 vsftpd
    25416 root 15 0 2096 1068 768 R 0.5 0.1 0:00.03 top
    23365 apache 16 0 7572 2772 1600 S 0.2 0.1 0:00.29 httpd
    23926 apache 15 0 7572 2840 1628 D 0.2 0.1 0:00.78 httpd
    24180 apache 15 0 7572 2844 1628 D 0.2 0.1 0:00.12 httpd
    24365 apache 15 0 7572 2836 1628 S 0.2 0.1 0:00.07 httpd
    24790 apache 15 0 7572 2948 1732 S 0.2 0.1 0:00.17 httpd
    24807 apache 15 0 7572 2776 1600 D 0.2 0.1 0:00.04 httpd
    25068 apache 15 0 7572 2808 1600 D 0.2 0.1 0:00.02 httpd
    25132 apache 15 0 7572 2948 1732 R 0.2 0.1 0:00.64 httpd
    1 root 15 0 1696 544 468 S 0.0 0.0 0:00.25 init
    Vmstat too:
    vmstat 3
    procs -----------memory---------- ---swap-- -----io---- --system-- ----cpu----
    r b swpd free buff cache si so bi bo in cs us sy id wa
    0 94 196 48928 5080 1905832 0 0 5574 507 223 122 1 10 18 72
    0 94 196 48936 5108 1906040 0 0 13000 43 6830 824 0 6 0 94
    0 87 196 48836 5120 1907012 0 0 12847 0 6828 783 0 8 0 92
    0 96 196 48892 5152 1907816 0 0 13332 23 7245 805 0 7 0 93
    0 91 196 49100 5144 1908476 0 0 12704 4 7027 802 0 7 0 93
    When i uploading something via ftp (vsftpd) about 20-30 seconds upload speed is 5-6 mb\s, but after that speed become so slow... and ftp connection go down...
    Please help me.

  2. #2
    Just Joined! lucazz's Avatar
    Join Date
    Oct 2006
    Posts
    1
    dude, I had just solved a problem just like yours, check your RAID configuration, there must be some kind of mess there..
    Here, all I've done is configure correctly the RAID configuration.
    Cheers,

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •